Blinking monitor, losing draft and sticky passing

About a month ago, I received an update which seemed to cause a few issues when riding in large blobs. I’ve used multiple PC’s and my zwiftilizer comes back clean, so I am not getting power drops. I use ANT+

  1. My monitor starts blinking when there are a lot of riders. If I move to the front where only a few riders are visible, it goes away. The riders (only) disappear. Their bikes remain.

  2. I seem to be losing the draft while in the blob. It feels the same as when you come through the blob to lead and then lose the draft as the group passes you. Only this happens when I am solidly in the blob, Suddenly, even though I am putting out a higher w/kg, the group started passing me and even when I do a higher wattage, it’s hard to stop dropping.

  3. I seem to be getting stuck behind riders much more often than before that update. Once I drop to the back of the blob, it is extremely difficult to get back towards the front. At times, I am well over a w/kg more than riders around me and I barely make up any ground. And once I do, I start dropping back again even though I am doing more w/kg.

I have tried different bike set ups. I have the concept bike, so I am not new to zwift.

What’s your fps p5 in the rides when the screen flicker?

It sounds like a pc problem.

I know why you keep asking this (in good faith) but don’t you think these reports are getting rather frequent? There’s not normally so many people reporting new instances of crashing, and riders disappearing etc. Something is wrong with the game.

I’ve seen it reported by people with GTX 1650 and 1070 graphics cards. These aren’t low end systems for Zwift.


Yes we do see them more often. It can be more people returning after the summer to find the latest version is more resource intensive or just more riders on screen. We tend to see it in big group rides.

But It can also be that there is something random happening with the code.

As you know it is easy to try and eliminate the obvious.


Perhaps we should ask the people WHERE it happenes…

Win 10 PC user, GTX 1650 (first year Zwift with GT 7xx - do not know exactly), using ZCA (Android, HTC U11). Had never problems - no dropouts, no crash. Now some crashes - always in France, in meetups.
On Wednesday I tried to combine a meetup with a workout - crash shortly after finishing WO (no action on my side, wanted just finish the route).
ZCA activity 10,20 km, no activity details. Manually loaded fit file to Strava 12.17 km.
Setup another meetup, just free ride - crash, ZCA 5.21 km, Strava 5.20.
One more meetup started, leaved it, made u U-turn, free ride for 12.1 km - no problem, saved.
Will take a look at the log files in Zwiftalizer later, was so frustrated that I forgot it…

Yesterday Quatch Quest, no issues.

Will test again, when France is on schedule (do not use any hacks, only tried the meetup).

Ride on!

1 Like

Do you have any config file mods? France in particular is susceptible to crashing with modifications I believe.

Hi Dave, not sure about the mods - I tried some in medium, because the GTX 1650 did not have ultra when I bought it. But now it has ultra and I think I did not touch the ultra file. Yes, there are many people with mods having problems (I believe it is mostly the Foliage).
Can I find the original ultra somewhere - would like to check it to be sure.

Thanks, Milan

ultra.txt just has this in it by default (and yes, that res is correct).

res 1920x1080(0x)
sres 2048x2048
aniso 4
set gSSAO=1
set gFXAA=1

OK, will try tomorrow - one more meetup in France, perhaps.

1 Like

same problem in this topic.

copy URL and remove brackets

1 Like

This has also been reported as per below.

The response I got from Zwift was my PC graphics card (NVIDIA GeForce GT 720M) was no longer supported. It was one day…not the next. I’ve tried to optimise my PC performance but haven’t managed to sort it out.

I’m hoping for a fix with the next update…or otherwise I might be up for a new PC.

1 Like

That’s ridiculous, they need to make it known if the minimum specifications are changing.

1 Like

Hi Dave, edited ultra file (back to the original), no crashes today in France & Paris (meetups).

But once I came near a race or group ride from behind … in some seconds (perhaps 50 riders on screen) I lost my connections (Tacx Neo controllable, NG Eco power + cadence, Quadlock HR). Down from bike, waited for a short time, menu, everything de- and reconnected, OK, rode R.G.V. without issues to the end.

Do you think my old (7-8 years) Intel i3 is the bottleneck? I think so… Can anything change with BLE or ANT+ dongle? Using ZCA now.

Thanks, Milan

Good to hear the crashing seems more stable. No reason why your connections should be impacted though, unless your system is hitting some power limit and it’s having to ditch peripherals to keep the core stuff maintained. But I’d doubt that tbh. In any case just make sure you’re set on high performance for everything, with power saving disabled etc.

Thank you Kurt. That is a great thread and explains exactly what I am experiencing. It seems that they do understand that there is an issue. It has a lot of responses and a lot of people reporting this issue. Very frustrating.

1 Like