Black screen when exiting Zwift post ride


(Zach Johnston) #1

Ive seen that this has been asked before (back in 2016) but it appears that there is no answer, solution wise.

Every time I finish a ride and save, I get a black screen and the computer is completely unresponsive at that point. No alt-tabbing, no CTRL-ALT-DELETE, no alt-f4, no windows key…nothing brings it back except a complete restart. Interestingly, my music thats playing in itunes continues to go.

Now interestingly enough, if I just open zwift and edit setting after starting a ride (because somehow thats still a basic user interface issue that hasnt been resolved after all these years) I can exit the ride without saving and it will NOT give me a permanent black screen.

Is there any update to this? I have a pretty solid gaming rig that Im running this on, all drivers up to date, and Im clearly not the only one to have encountered the issue.


(Vincent W.) #2

Hey Zach, sorry Zwift isn’t exiting properly! How long have you been experiencing this error, since the latest update? And have you tried uninstalling Zwift then reinstalling it with a new application download to see if that helps?


(Zach Johnston) #3

Whoops I missed the reply, sorry!

Ive actually experienced this since starting zwift early last month, bought the Cyclops H2 bundle. It’s always been an issue.

I have NOT tried uninstalling/reinstalling, I will give that a go and when I ride again tomorrow Ill report back.