Badges not showing up

Quick badge question for you. I rode two courses in Yorkshire a few days ago, Tour of Tewit Well and Duchy Estate, both badges showed up at the end of the ride, exited Zwift and uploaded to Strava fine, both Zwift Activity and the companion app show that the badge was received but it doesn’t show up in my Zwift in-game badge library. Rode yesterday (got the pump room 8 and addicted badge, both showed up) and today (rode queens highway and 2019 UCI And both posted correctly as well.

Wondering if there’s a way to get them to show in Zwift or if I have to re ride it.

Thanks,

-J

Do you have the zwift game installed on more than one device? Eg one on a iPad and one on a pc? Often problems can happen when zwift thinks you are still logged in on another device.

1 Like

I do, but was only logged in on my MS Surface Pro at the time.

My only suggestion would be to force quit the app on all devices and then open it on one device and have a look at the badges. If it’s still not there then I’d be inclined to ride it again. However, the fact that it shows on the website means you shouldn’t have to.

Tried that, all apps are closed. Rebooted the PC too. Still not showing.

I’ll reride the short one tomorrow to see and go from there.

Thanks for the reply’s.

2 Likes