Bad service

I cannot access my account to ride. When I click on my account the system takes a long time to respond and only responds with the message “you cannot access that account right now”. The internet connection is excellent. My account is paid. My password has not changed. My app is up to date. I am accessing Zwift with apple TV and smart TV. All devices are working correctly and their software is up to date. What is going on? Why can’t I access my account and ride?!?!

Are you force closing the Zwift App: https://support.zwift.com/en_us/force-closing-zwift-rkI3Rp7yP

I attempted to call Zwift. Their system routed me through a series of computer controlled receptions and placed me on hold, then disconnected me after the computer stated no representatives are available. This occurred after I attempted to contact Zwift on line through their “chat” link and email. Those also did not work and mislead me through a similar series of fruitless attempts that were nothing but a waste of my time. So. I attempted the “chat” and email methods numerous times. They are also worthless. They programmed their system to automatically respond to customers emails with the following message -

“Hi , Thanks for reaching out to us! We’ve received your email and look forward to speaking with you! We will get back to you as quickly as we can. In the meantime, have you checked out our Community Forums? Your question might already have an answer there! We look forward to connecting and thank you for your patience! - Your Friendly Neighborhood Zwift Support Team”

This has been going on for hours. No one at Zwift is responding, the problem continues, I cannot ride on Zwift although I have paid for it. Their website reports that there aren’t any problems, but there sure are a lot of complaints on the internet. Looks like many others are experiencing the same problem as me today. They programmed their website to report no outages or issues when there are some. I also see they are charging customers credit cards the month after customers cancel membership. They programmed their website with an excuse for their credit card theft. Illegal theft. Class action lawsuit maybe?

Extremely irksome worthless “customer service”. It’s more like screw the customer than “customer service”.

The issue could be with your ISP or routers in the area since there is a little storm heading to that part of the US right now.

I just tried logging into and I had no issues (Midwest USA).

I just tried logging into and I had no issues.

Also an ATV user and just logged in with no issues (east coast U.S.).

1 Like

where are you seeing this?

Did you try force closing like Paul mentioned? How about restarting your router and wifi modem? Power everything off, unplug it and then restart everything.

2 Likes

Maybe the storm has something to do with it.

Hurricane Laura

1 Like

They programmed their website with an excuse for their credit card theft. Illegal theft.

According to ZC, you rode in France 8 hrs ago (that would be after your original post). Apparently you got your system working? Care to tell what the solution was?

1 Like