Avatar wont peddle


(Dan Steringa) #1

Why is it that at total random, my avatar wont peddle.  Nothing is more frustrating then getting all ready for a ride and then the avatar just sits there coasting.  The watts show up fine. It doesn’t matter if I switch hardware, uninstall the program and reinstall it, power down, power up etc.  Then out of the blue a few days later it can work fine.  


(Dan Steringa) #2

I am using a Tacx Genius


(Paul Graham) #3

Shouldn’t really have to, but I’d recommend fitting a separate cadence sensor on the arm of the crank Dan.

There does seem to be random issues with cadence data broadcasting from the power unit.

A quality separate cadence sensor will fix it. What hardware/computer are you using?


(Stephen Higgins) #4

I’m guessing your cadence sensor is dropping out. You’re not the only one, I’ve seen people whizz past me with their legs totally stationery, it does make me chuckle, like their using an electric motor.

 at least your watts are working, unlike mine.


(Dan Steringa) #5

I have a Wahoo Speed and Cadence sensor on the bike already, the option to pair it never appears in the menu.  The sensor works fine with my wahoo elemnt.  


(Stephen Higgins) #6

I have a Garmin cadence sensor and it pairs at the opening screen, but it’s always the last thing to pair up


(Paul Graham) #7

If I’ve got this right, your Tacx broadcasts power and cadence. Speed is calculated from the power data by Zwift.

So technically, Zwift is ignoring your Wahoo speed/cadence sensor in favour of the Tacx power/cadence data.

On the pairing screen you will need to ‘un-pair’ the Tacx cadence and search for the Wahoo cadence sensor. (Zwift does not need the speed part of the Wahoo sensor).


(Dan Steringa) #8

Hi Paul. Sorry for confusion. Wahoo speed n cadence sensor never shows up as option to even pair. At the login screen it shows I’m connected via BT to my Tacx for power and cadence. However, when I ride, the avatar won’t peddle. I’ve never been able to get my wahoo cadence sensor to even appear as a pairing option from the menu, yet it works fine with my wahoo elemnt on the road.


(Paul Graham) #9

Can you upload a screen-shot of your pairing screen Dan?

If you leave your Tacx unplugged from the mains does the pairing screen ‘see’ your Wahoo device (you will need to be pedaling). If it doesn’t show up, It’s possible that your current Wahoo sensor is not working correctly… 

The problem I have read seems to be the Tacx power works fine but the cadence component can be random once riding.

This is where fitting a functioning separate cadence sensor would help. But it will only work if the Tacx cadence option has been dropped/un-paired

 


(Dan Steringa) #10


(Dan Steringa) #11

I will try later to see if I unplug the trainer, that my sensor will show up.  Thanks Paul, hopefully the screenshots show what you were wanting to see.  As you can see, my watts are fine, but the cadence shows zero.  I started it up last night and it worked fine, it is totally random (1 out 5 rides, I would guess), where the cadence is not working despite it being connected.


(Lori Schoenwald) #12

When my cadence drops to below 50, I lose my cadence and my avatar stops peddling. I’m sure it looks odd when I pass others on hills and they see I’m just coasting. I figure it is due to the low cadence.


(Paul Graham) #13

You’re right Lori, more directly, low cadence is interpreted as zero power too, so your avatar goes into coast mode.

On steep declines your avatar will move into the position-of-least-resistance, sitting on the cross-bar  :slight_smile:


(Dan Steringa) #14

The video was just the beginning. My cadence was high, it’s just an intermittent issue. Totally random. Tacx is replacing the motor.


(Dan Steringa) #15

Update:  Tacx has since replaced my Tacx Genius Trainer.  My question now is, when logging into zwift, which option do you want to choose - (Paired Devices Screen)

  1. Power Source, or

  2. Controllable.

or is it both?  I used to select all 3, the 2 above plus Cadence.  On my new unit, I was able to zwift fine (using Apple TV) but at the “Paired Device” screen, the “Controllable” option is not able to be chosen now.  

I also can finally choose my Wahoo Cadence sensor, which leads me to think the past unit did in fact have a faulty BT connection.