Avatar not advancing - cadence sensor pairing seems to be the issue

I know this has been discussed elsewhere before but i think i have a different set up. Can you take a look at this please, on its unique merit?

Please eliminate that other possibility: i am a paid subscriber.

Current setup:
-Wahoo kickr core
-Apple TV: i use the Apple TV remote control to launch Zwift, I only use Zwift Companion via my iphone once Zwift is fully launched
-distance between wahoo kickr core and appleTv: a few steps
-I launch TrainingPeak for my workouts within Zwift

Issue, and troubleshooting applied to date:
-new recurring issue: despite all three systems - power source, cadence, and controllable - showing as connected (in blue with green checkmark saying connected), my avatar just sits on the side of the road and wouldn’t move. I did notice since the beginning: the power source and controllable connect right away, with the cadence sometimes requiring me to tap on the orange tab to activate it and for it to turn blue. The system does seem to respond better if i make sure the button that says “pair with Zwift companion” is enabled, else, if i click that/turn it off, the power source and controllable would say no signal, and then my problem is worse: i am suddenly disconnected from all.
-i have tried a different order of turning devices on: unplug the wahoo kickr, wake the bike, turn on appleTv, launch zwift, ask it to find power source, etc., plug the wahoo kickr until all three systems are connected
-i have disabled the wahoo sensor from the wahoo app on my phone (and will only add from time to time to update the app)
-the wahoo sensor is up to date (i have the “latest” version, it says at the bottom of the app)
-i have disabled bluetooth on my huawei tablet
-i have disabled bluetooth from my personal iphone
-i have disabled bluetooh from my work iphone
-i have recalibrated via Zwift not via wahoo app (trying to be consistent by doing it only in one place)
-if/when i am able to finally connect, and i start my TrainingPeaks workout on ERG mode, i notice weird resistance come on in the beginning, with RPM showing a lot of bouncing up and down, but I am definitely having a hard time getting to the cadence the workout requires. Even though it feels like my legs are spinning as fast or faster than the required cadence, i couldn’t get there, and sometimes the RPM would go down to something as low as 3! I shift gears up and down to help ease the tension and i am not sure if it’s doing the trick, but it would take about six minutes for the RPM to settle down. I do not think this is normal.


  1. is there a known issue in launching the TrainingPeaks workouts via zwift e.g., compatibility issues?
  2. how will i know if it is a hardware issue? What are the indicators for it to be a wahoo kickr hardware issue?
  3. are there known bugs between appleTv and wahoo kickr core pairing, in particular on cadence?
  4. is there a right order for turning on the various appliances?
  5. is it normal for the cadence sensor to lag behind in pairing. As noted above, the power source and controllable instantaneously link up, showing as blue, but the cadence sensor would lag behind (or not connect at all).
  6. Is there any physical adjustment that needs to happen on the bike, the bike pedals, the wheels, or the wahoo kickr core hadrware, to help render the cadence sensor more sensitive to the pairing?

***IMPT: I do need help to solve this issue ASAP because i am training for, and have earmarked March 26 for my v-Everesting.

Thank you!

Can you ride ok in free ride mode (a normal ride and not an ERG mode workout)?

In the pairing screen, when you’ve got the power device paired, if you then pedal does it show you producing power, or does the watts indicator stay at zero?

1 Like

Hi! Thanks for quick check in.

I just tried it.

Turned on AppleTV, monitor, asked it to search for smart trainer, plugged my trainer. All three immediately went blue, and indicated connected.

Did not launch workout just clicked on ride.

Negative. My avi, she didn’t move.

Watts indicator stayed at zero.

Thank you.

~sent from an iPhone

Your watts staying at zero is why your avatar is not moving. So we need to look at why your watts are zero. Zwift isn’t receiving any transmission of watts from your trainer for some reason. Let’s leave the cadence sensor for now, because that’s secondary to not registering any power.

If you pair it to the Wahoo app rather than Zwift, you’re saying that calibration still works correctly?

What about if you try launching Zwift (the game client, not the Companion) on your phone and pair the trainer to your phone, do you get watts when you pedal then?

1 Like

I’m interested in this thread because I frequently get power and cadence paired but falsely showing zero output with a Kinetic inRide module paired with a PC. Sometimes restarting Zwift and not starting ZC till afterward seems to help. I do also now have a separate Wahoo cadence sensor and not as many problems with it

1 Like

You have at least 3 separate systems for Zwifting available to you.
The Wahoo kicker appears to be the one that you have trouble shooted the most.
Steve has given you some good advice to get started.

#2, The speed sensor is always an option but you will be on Zpower and it also depends on if your dumb trainer is supported (kinetic ?).

Option 3, Kinetic InRide, just had issues with their app but those are resolved but may require uninstall and reinstall the app then performing the Kinetic sensor pod reset protocol where you flip the battery.
A Google search will show it.


Ok. I just tried this:

I launched Zwift game from my iPhone.

Plugged smart trainer to electric source until the blue light blinked.

Zwift game on my iPhone immediately lit up indicating connected. Blue on each of the three. Green check mark :white_check_mark: on.

I clicked on ride (still on iPhone Zwift app), non ERG, just regular ride.

Negative. Avi did not move. And still at zero watts :frowning:

Thank you.


~sent from an iPhone

Emily, are you also talking to Wahoo? Because that’s really what it sounds like

1 Like

Do you have the Wahoo Utility app on your phone? Wondering if you connect to that app if it will show watts and cadence?

Also, it is suggested that you use the manufacturers app to calibrate the trainer, not within Zwift.

1 Like

If it’s not giving you any watts on both your Apple TV and your iPhone, then I think that it’s time for you to contact Wahoo support. Something doesn’t sound right, and perhaps it’s your trainer that is faulty.

1 Like

Hey Emily

This happened to me when I first got my Kickr Core. After a long back and forth with Wahoo tech support and a number of phone calls, they replaced the Core and I was fine after that.

I had the same setup as you - Core and Apple TV. And everything would show as connected. While I never found out what the issue was, I suspect it was a faulty Bluetooth connection.


That was a great test to isolate the issue - do a workout mode on wahoo without launching zwift— after I’ve troubleshooted with launching zwift vs appleTv and launching zwift vs my iphone.
I also took a picture of the wahoo workout screen, and it showed the following: workout time 53 seconds,speed 23.1, distance 0.25, BUT cadence stayed at zero, and power stayed at zero.
It does look like a wahoo smart trainer issue.

Leading to this, I’ve been having a lot of issues with the spindown - either with zwift or doing it directly via wahoo app, same experience. Despite having ‘woken’ up the bike and the smart trainer beforehand, despite accelerating slowly as instructed to the required 36kph speed, and despite pedalling like a madwoman (and i know i was hitting those speeds), the dials would not completely go to 36kph, i look longingly to hit the summit, and to my chagrin, even as i pedal faster to keep it there and go higher, i helplessly watch the numbers go down on its own, recuperate i.e. go back up again, despite me being consistently keeping my speed up. It was very frustrating. I wondered if it was an indication of malfunction. It’s not supposed to be that way, right? The spindown should not cost me more effort than the climb to ADZ! This wasn’t the case in the early life of my wahoo trainer which was not that long ago (end october 2020).

ONE LAST REQUEST FOR HELP PLEASE: For getting faster wahoo support and a nod for a replacement, should i go to the main Wahoo support folks, or to the local store i got this from (they are closed today).

I need to get this sorted out ASAP as I am currently training for, and will be doing vEverest on March 26. Any tips on the better strategy to contact Wahoo as per above, would be great.

Hi Federico, did you connect with the Wahoo main support guys, or the local store you got the trainer from? Thank you!

[email redacted for privacy]

I went straight to wahoo but I also bought from them direct. It depends if the store has another one they can give you straight away.