Avatar wont move with Wahoo Kickr

Hi there, I have a Kickr Core and was using a Mac, connecting through BLE to ride on Zwift. It was working fine for months. Then drops started to happen more and more. One day I started a ride and my avatar wouldnt move. Here is some info:

  • I have a Kickr Core
  • I run Zwift on a Mac Air
  • In the Zwift pairing screen I have connections with Power Source, Cadence and Controllable
  • In Zwift ride I see NO cadence and NO power and my avatar DOES NOT move

This is what I have done to isolate so far

  • I purchased an ANT+ device and installed that. This did not help. I paired correctly with ANT+ but exact same results. I.o.w. I have the exact same problem whether I connect through BLE or ANT+
  • I installed Zwift on a PC/laptop and tried a ride on that. Exact same results.
  • I checked in the Wahoo app: I am paired with the trainer but I see no cadence or power when I satrt a workout in that app.
  • I checked my Zwift subscription and I am still an Active member, my subscription hasn’t been paused.

I have attached some screenshots.

Any help would be appreciated :slight_smile:


Hi @Nils_Nugteren, welcome to the forums. The fact that you are having the same issue on multiple devices and both in Zwift and the Wahoo app Ieads me to think the issue is the kickr core. I would suggest opening a support ticket with Wahoo. Your core may have failed.


Mike, yes, thought it might be that unfortunately…thanks for your feedback!