Avatar moving back & Forth

Noticed in last couple of events (WTRL) my avatar is constantly moving back & forth like on a yoyo (but not like slingshot through pack its more a graphics thing) and its making my head ache watching it!

Anyone else experienced this? Running Nvidia 1070 with up to date drivers & I7 processor and its only happened recently.

Uploaded zwiftalizer below

Thanks in advance any inputs

Happens as the frame rate passes through 60fps, never known why. It’s not new though. Let me know what display you’re using and I can advise the optimal settings.

Thanks, Ive got this display

Right, so given that it’s a proper G-Sync monitor you shouldn’t have had anything to do. Just make sure vsync is enabled (‘use the 3D application setting’ as default is fine, no need to manually change it).

Your frame rate seems a bit low tbh, but chances are you’re CPU bound in that ride. In which case you should consider capping the frame rate at 59fps. This will limit the frame rate when it could be higher, but means you’ll never get the rubber banding effect. You’ll not get any stutter or tearing because you should be within the adaptive sync range almost all the time. I can’t find confirmation of the specs but it should be at least 48-144Hz.

Thanks for your assistance on this, my VSYNC is currently set to this

Should I force it on?

If that doesnt need to change/solve it capping frame rate done within NVIDA I assume rather than zwift itself?

Zwift forces vsync by default, so that setting is fine and you can leave it as is. This isn’t anything to with the rubber banding, it’s just that a lot of people disable vsync to chase FPS and all they’re doing is introducing tearing for no reason. Yes, cap the frame rate in that menu, it’s a bit further up.

Is G-Sync set up correctly?

Just noticed GSync is setup for full screen mode only but I run zwift windowed so have changed this setting, will run tonight and see if different, if not will adjust frame rate to 59 as suggested

The game runs a lot better in full screen mode IMO but yeah give it a go. I suspect you’ll benefit from setting the cap anyway. :+1:

thanks so much appreciate the help, agreed but find it easy to jump around with spotify rather than sweat all over phone but will try it out :slight_smile:

1 Like

adjusted frame rate for zwift to 59 and worked perfectly thankyou for help.

1 Like