Audio echoing and VERY LOUD [1.31] [November 2022] [SOLVED]

Doing a custom workout in Fine and Sandy, and have all Zwift sounds turned down, and can’t kill the sea gulls! I did Island Hopper last night and did not hear them.

Is it only on this route?

Please make it stop! :tired_face::man_facepalming:t2:

I really enjoy riding the NY maps, but man…that noise is unbearable. Is the Zwift team any closer to getting this resolved?

They’ve said the fix will be in the next release (1.32, presumably in December). Apparently they are not willing or able to release it as a patch to 1.31.

Last week I have experienced the same problem on Windows 10 when riding “ Zwift - Group Workout: Arise (E) on Douce France in France”. As a matter of fact, it killed my Yamaha AV receiver because the software asked to much of it. Today I replaced my receiver and started again to zwift in my pain cave. The same problem appeared in Richmond, so I ended it. Than I tried Watopia and there wasn’t any problem. I am very sure that my receiver died because of the sound settings bug. I am wondering if Zwift has any kind of policy for this kind of problems… Does anybody know something about this?

seems madness not to have updated this yet - seems like it should be an easy fix and is really annoying

1 Like

Based on Fabi’s points, I did the following workaround on OSX after opening a terminal. The results seemed fine (no sound whatsoever). I have my sliders to zero anyway since I’m listening to music while Zwifting, so this is a way for me to force the sound to zero on the Zwift app and allow my music player to play. For me, I don’t care about sound in New York, Watopia, or anywhere else, so this worked fine for my case :slight_smile:

Warning: Never copy commands from the internet into a terminal without understanding what each line is doing!

I did some experimentation following the lead of Fabi and it appears that just removing the contents of the single file Main.bnk from the directory ~/Library/Application Support/Zwift/data/Audio/OSX/ is adequate to completely remove all sound from the game.

# moved it somewhere else entirely
mv ~/Library/Application\ Support/Zwift/data/Audio/OSX/Main.bnk ~/Main.bnk.old

If you don’t like the terminal, in Finder navigate to your home folder, then to Library/Application Support/Zwift/data/Audio/OSX and delete Main.bnk.

If you want some sound to work (vs what I wrote which removes all sound), you might need to do some more experimentation (likely on the file World9.bnk) in the directory listed.


Still no fix from 10th november? Awkward … im in the free version but im going to cancel my subscription right away - dont want to listen to screaming speakers …

If you’re in the free version just don’t sign up until it is fixed, should be fixed in the next updated which should be out in under 2 weeks.

Not defending it but it is what it is.

Cool to hear this actually works! :smiley: Support told me they would adress the issue with the next update. Could just make a script to turn it on/off on demand if it takes longer.

So far I only had the issue in Innsbruck @shuji it was permanent everywhere, also keeps on playing then sound after dropping back to menu untill loading another world. I.e. at Lutscher right at the spawn/start point.

1 Like

I would give them a chance. The next update can´t take forever. No reason for me to defend Zwift Dev Team at the price they are asking andI am not working for Zwift or anything like that. At the other hand I spent enough time in this game (13.000km this year) and have not encountered any serious game braking bugs and updates have been almost weekly. It´s not a normal computer game, it is a training app, but it makes sense to compare it to actual games with similar subscription models. In my experience a 100% bug free game is quite impossible. For those kind of games where people have to pay for a duration, bugfixes should happen fast. Or people will react and leave. Yet it is understandable that nothing can be fixed overnight and stuff has to be tested, so the story does not repeat. Rushed updates can also be bad. So l hope the next one will be tested well.

I will and I understand … i’m from IT sector so I know it all.

But here is no visibility about release date (I haven’t noticed any useful post) - and I’m in age where time is more important than anything else.

At least I will try Rouvy so I can compare later :slight_smile:

updates are monthly and usually towards the end of the first week (give or take)

1 Like

Main issue with this is alot of people are wearing headphones and to get a ear piercing sound that loud into the ears is not good at all. Plenty of people who are sensitive when it comes to noise. This should be a priority to fix ASAP not waiting for their next release because this could seriously cause people some issues.

This one is a duty of care to protect the hearing of people and not a normal bug that can wait.

Zwift have a duty of care and currently are failing to adhere to this and could be held accountable if something bad was to go wrong due to it

Ignoring a user setting for audio output is a serious breach of expectations for the behavior of any software, and it should have prompted a patch release with a fix within a couple of days at most. The fact the bug is still unfixed after 3 weeks of being reported tells you 1) they’re seriously incompetent, or 2) their processes are seriously broken. Or both.

What’s worse, the suggestion that the problem should be mitigated by setting the sound output of the whole device to zero is simply scandalous. Your app is just that: an app, and has no jurisdiction over what I do with the rest of the OS/device, something Zwift is happy to break here, just like they do in the behavior of the full-screen app on a secondary display, as many users have reported over time.

Not just the expansion. Think of all the new users and engagement that the Mark Cavendish activities will bring. And I bet the Cav contract is much more expensive than a few days worth of testing, which shows you what their priorities are.


My guess is that all holiday was cancelled while the new expansion was being worked on and so once that was released all the developers took their time off afterwards and so there isn’t anyone around to fix these issues. throw in to that thanks giving and it is the perfect storm!

I meet this annoying sound today in NY even if sound slider is turned off. Harsh experiece…

Do they actually test this stuff before they release it? I know they are paying Mark Cavendish a truck load of cash to jump on Zwift every day, but you’d think they would have enough resources left over to fix a few minor bugs…

Seriously when will this be fixed??? Even if I turn game sound off it still blasts at 1000, and if I must tv then I can’t listen to my music set up. Fix this please

It took them 12 months to make 12 miles of new roads.

6 months ago Zwift laid off a large number of staff, one of which was the lead game designer. Since then Zwift quality control, which wasn’t that great to start with, has taken a nose dive. It’s no coincidence.

I tried to join a race in Innsbruck last night only to be greeted by the noise bug and as I am on iOS there’s no workaround.

Is it going to be another week of having to avoid courses because of this bug?

1 Like

Just turn the sound down on your device. Not ideal but should hopefully only have to do it for a week or so.