Assault air Runner Connection Issues

Hi everybody,

I have just bought a Assault Air Runner which i hope to use with Zwift, so far i can connect on the pairing screen but my Avatar won’t move in game. Whats strange is i managed to get it work once through bluetooth but nothing since through either bluetooth or ANT.

I would like to use it directly using the monitor but failing that i have a Runn Device from a old treadmill but i need to get some new stickers for it or i can purchase a Stryd device for another £200… I also have a Garmin watch which i thought might work through virtual run mode but so far no luck.

Does anybody that owns the treadmill have any experiance with whats the most acurate and works without any messing around everytime you want to connect? Its a bit disapointing i have spent this much on a treadmill and it doesn’t connect :pensive:

Apologies but I can’t help you with your connection issue.

However if you have a working Runn you wish to use you certainly do not need to buy more stickers. Tip-Ex correction fluid works perfectly well, well it has for me these past two years.

I’m sure you will get some help here but if not try Zwift Runners Facebook.

1 Like

You could try pairing it via the QZ app ( If you have questions about it, ask the developer @Roberto_Viola

Another option would be trying pairing via the Companion app to see if it behaves differently


Qz developer here, let me know if I can help you!

I’ve seen your likes on my other Airrunner posts, so you will know that I use Stryd for speed and cadence. However, I just tried pairing my Airrunner with Zwift on my tablet and I got it to work twice, with one failure in between successful attempts.

It appears the Bluetooth pairing is not remembered and must be re-made each time you want to connect. Furthermore, if the connection drops then it might not be restored successfully.

For example, the first pairing was successful and led to the example above. I then went to the Zwift pairing screen, which seemed to start things over, and although I could see and select the Airrunner, the was no speed transmitted. I had to press the Bluetooth activation on the Airrunner once again to re-pair the treadmill and Zwift. This time the speed was picked up again, as with the very first connection attempt.

There is none of this nonsense with Stryd (which you will note is connected as my cadence sensor, even though I was not wearing the Stryd and did not (knowingly) activate it). It’s just always discoverable via Bluetooth, even when “dormant”.

At least the speed shown in Zwift did match the speed displayed on the treadmill, allowing for rounding and lag. Personally I would not bother with it again, not least because I have Stryd, which is 100% reliable so I have no interest in hoop jumping every time I hit the treadmill. But maybe it will work well enough once you get to grips with its short attention span.

1 Like

Thanks everyone for the sugestions, I did have a bit of interest in the Stryd for outdoor runs and after messing about for half a morining trying to get this to work thats the option i have went for, I am a bit disapointed that it looks like zwift have not fixed this in a update and i hope they do in the future but for now i will try the Stryd

I did get it to work briefly using this method but it was stuck to the same speed, infuriating to say the least! I will go for the stryd as it looks to be a realible option and has the plus that i can use it outside and when not using zwift. Cheers

For me the assault runner works flawlessly when I connect directly to the device.

With the companion app I sometimes have signal drops.

No problems connecting to iPad, iPhone or Apple TV.

PC was also without problems, took a bit longer to connect and I had the Bluetooth dongle on an extension cable right next to the air runner.

I would try different devices with direct connection. If that’s still not better I would want to have assult send over a new head unit.

And before I forget, I had the speed cable come loose on me twice, leading to a connected device but zero speed readings.

I don’t know how it could get loose but after making sure every plug was connected real tight inside the tubing it returned to sending over speed.

1 Like