Arrow keys do not work as expected (custom workout editor, end ride screen, drone camera, U-turn, intersections) [1.39.0][May 2023]

  1. You need to download the .zwo file and copy it to your Zwift directory

  2. It seem to be working for me.

Hi Team
I just downloaded the latest version of Zwift to my Mac (running OS 13.3.1) and the Custom workouts functionality is causing me huge issues. I have used this before and never had an issue. Basically when trying to change the time or watts (for example in the ramp up) it is impossible to move to the right in the field, instead the cursor just jumps to the next field. For example if the default watts for Z2 ride is 180W and I want to change this number to 185W I cannot get the cursor to go to the far right of the field instead it just adds number in front of the 180W. Clicking the right arrow or moving to the right just takes me to the next field. Incredibly frustrating as I have not had this issue before

thanks Gerrie. Workout is now in my Zwift Folder.

Still unable to get down to 10s. I think something bigger may be afoot.
When I first started setting up my custom workouts, I was able to type in the duration bubble. Now it just wont let me. And sliding it won’t let me lower than 30 sec.
Anyway, one part of my puzzle is solved at least.

Yaaay, I got it!
On Macbook: click in the bubble you want to change, hold function key down and hit right arrow to backspace, hit delete to delete what is in bubble and then you can write what you want. Not sure why I have to do it this way now as before I could just click in the bubble and write over. Oh well…
All sorted now.

1 Like

Hi, today i couldn’t edit any workout in power and in time. I use Mac, can be a problem for iOS?

Hi folks,

There are a few known issues occurring in the 1.39.0 UI around the use of arrow keys on the keyboard. We are addressing these, but I’ll make sure that any new reports are investigated and report back with workarounds where possible.


  • If you’re blocked from editing duration and power targets in custom workouts, the current most reliable workaround is to drag the side of the workout block to adjust duration, and drag the top to adjust power.
  • For issues editing your activity title, the left arrow seems to work fine, but double-clicking within the text field will allow you to select and rewrite the whole title.
  • Drone camera issues are not fully reproducible, but currently it appears that moving in-world will allow you to pan the camera
  • If you’re having issues U-turning or selecting a direction at an intersection, you should be able to select these options with your mouse, or connect Zwift Companion to use the ZC Dashboard action bar.

Will I need to use the fn key + right arrow to adjust the watts in my custom workouts from now on or are you guys still working on it?

I am using an M2 Mac Mini, and having way more issues than the arrow keys. It makes me wonder if anyone actually tested that last update before it was shoved out the door. The whole thing seems to be a hot mess. Can’t edit custom workouts (I’ve been using BBEdit and editing them that way), the ‘Zwifters Near You’ is a complete distraction, and more…

It’s hard for me to believe that this is all from changing the UI platform support. How long until the fixes, and if it’s ‘real soon now’, can Zwift rollback to the previous version?

The FN + arrow keys is fine, if it works, but I don’t have enough room for my keyboard to edit Customs, and the problems using my usual method (using Screen Sharing is even worse than trying to edit them in the same system!).

To have one of the best UI of the apps I’ve used, and have these crazy issues is shocking and disappointing. Waiting/watching for the update and hoping it gets us back to the greatness.

But on a positive note, I do have full shadows for the avatar, and am loving the detail in the skies in Watopia. (Is that a galaxy I’m seeing in the sky in Watopia?) The moon is a knockout! Nice…

1 Like

Thanks!!! This worked!!

The arrow keys also no longer navigate the garage selections for kit, bike, wheels etc.

Yes, I am having the same issues. The FN key workaround no longer works. I’m trying to adjust the watts and time within the workout and each time I try to adjust it, that particular interval is deleted. This is so frustrating!!!

1 Like

For easy changes, you can edit the physical ZWO workout file. It’s not that hard, just don’t change too many things. It’s a fairly straight forward programming language. I was even working on an app to actually build workouts outside of the Zwift app, but since it’s not such a huge percentage of the population, and the workout editor was working so well, I dropped it…

But who tested the update and didn’t catch that arrow keys weren’t working. There are some good things in the updates, but…

It’s funny, but what, 5 years ago now, I was having a problem with a 2T trainer, and called support. I got some guy who said that using the trainer in ERG mode was ‘not supported’, and who just rides in ERG mode all of the time. I was basically wasting the technology by just doing workouts. I played support agent roulette and got someone else who appeared to honestly want to know who I talked to before so he could thump them on the head. But anyway…

Waiting for the next update…

Unofficial Zwift Programming Language Reference

The workout files are in (on a mac)

Documents/ Zwift /Workouts /<your ‘user number’, a 7 digit numerical string>

I would assume the path is similar on a Windows system.

If you don’t want to edit the text file you can use:

HAH! And I just edited a file yesterday, and the app left an interval ‘ghosted’. No target goal for the interval. It was just two blocks with nothing. Weird… I could not find any reason for it, but after C&Ping a line from another block, it worked. It’s pickier than I thought. :open_mouth: :dotted_line_face:

The left key hasn’t worked for me activity title since the upgrade. If it does anything it moves to the very left of the entry but more usually just loses focus on the text field.

Drone hovering has been better for me recently, not sure if it has been patched in the 15 days since this post?

Hey all - this issue has been fixed in game version 1.41, which is rolling out over the next couple of days across all OS platforms. Please update when it is available to you.

Is the fix only for OS? I have deleted and redownloaded the app for windows and still can’t create custom workouts…

The “drone camera” (0) view navigation is still very broken in 1.43 on Windows. Pressing the up arrow opens the action bar, etc. Please tell me it is not a “won’t fix.” It’s one of the best aspects of the game for enjoying the scenery and creating interesting YouTube/Twitch content.