Custom Workout Creation Not Available [Mac] [1.39] [May 2023][SOLVED]

A Zwifter brought up that the workout creation on Mac was not working for them. I tried this earlier tonight and I found that I was experiencing the same issue. All of the custom workouts can still be located, it’s just that the workout creation is not available. However, I did find a workaround.


  1. Find a workout that you have in your library
  2. Click the duplicate button (two cards overlapping I believe)
  3. Delete the blocks and create your workout

I am experiencing this issue on MacOS 13.3.1 with game version 1.39. Please chime in with your setup details if you are experiencing this issue too. This helps Zwift see whether this is a widespread issue or just a one-off.

Ride on.


We made a change earlier today on the server end that should have resolved this. Please let us know if this has / not been fixed on your end?

Works now!

1 Like

27 posts were merged into an existing topic: Arrow keys do not work as expected (custom workouts, end ride screen, drone camera) [May 2023]

Hi @Allan_Schroeder welcome to Zwift forums!
I merged your post into this thread. We were seeing some issues related to custom workouts last week at we resolved on the server end.

That will be resolved as long as using Zwift v 1.39. If you start Zwift by clicking the ZwiftAppLauncher icon - it should automatically update you to the latest available version. If you bypass the Launcher app - you may still be on an older version.

2 posts were split to a new topic: Cannot create custom workout since update (Today 9th May 2023)

Hi All,

I wanted to clarify that the issue on this thread has been fixed. If you are having difficulty using the keyboard arrow keys to edit your custom workouts, we are working on a fix. The discussion is over here at the moment.

1 Like

I am quite confused about how to find the version I am running on MacOS. Because I see that my launcher’s version is 1.1.8 (and I just downloaded from the Zwift download page now - MacOS Download link). But when the game starts, it opens another app called ZwiftAppMetal, and I cannot find the version of that anywhere.

I tried quitting and restarting it hoping for the auto-update but I am still seeing the issue.

Hello @Edoardo_Lanzini , welcome to the forums!

On PC and Mac, you can see the Zwift version at the bottom right of the Log In tile when the Zwift App launches (on mobile platforms and Apple TV, it’s visible at the bottom right of the log in screen). You won’t often need to check your Zwift version, since the launcher will update for you as soon as possible.

The issue on this thread was actually closed on the back end and did not require an update to fix. If you are able to see the option to create custom workouts on your Mac, but are having trouble editing the workouts you create, you are experiencing an issue that we are still fixing.

Anyone else having issues using the workout creator? My issue is pressing the right arrow key to try and delete the pre-populated time or power figure for a block just tabs out of it and to the next field. No way for me to create or edit existing workouts…?


My custom workouts can only be created on desk top at present and not on my iPad or iPhone, also they cannot be adapted or changed on these devices can anyone shed some light on this?


1 Like