Arch sounds and ride on play at full volume regardless of setting

Platform: Windows 10

This has been a problem for a while now but today I did some further testing while in a training session. The results are quite odd. I initially noticed an imbalance between arch sounds, ride ons and general Zwift environment sounds. I tried to turn these down through the menu but it had no effect.

I turned the volume up to 50, I could hear the Zwift environment sounds respond.
I turned the volume down to 1, arch sound still played through speakers loudly, environment was inaudible.
I changed the default audio device to my monitor instead of speakers, arch sound still played through speakers loudly.
I muted the default audio device completely, disabled all other sound devices, arch sound still played through speakers loudly.

How are these sounds completely bypassing the Windows audio subsystem? When I mute the sound everything else stops but they still play and seemingly with no respect to volume settings.

Default speakers are analog wired to audio jack on PC motherboard.

Not sure about Zwift overriding your computer’s volume :thinking:. But in the game settings there are two (I think) sliders for volume. One is game sounds, the other is something else (can’t remember off the top of my head). Did you make sure you have that/those sliders turned to the level you want?

Yes, there are 2 settings Game Sound Volume (Menu and Notification Sounds) and 3D World Volume (Nature and Bike Sounds). The Game Sound Volume adjustment seems to adjust notification sounds like when people hit the thumbs up, hammer etc.

Don’t know why it doesn’t seem to work for receiving a ride on or going through an arch, it’s like those sounds are being played differently. I’m a software engineer that works on audio apps for a living and I’m pretty stumped.

OK I finally figured it out, not the PC at all, it’s the companion app! I couldn’t figure out why it was intermittent, would be ok one day and stupid loud the next.

I was turning up the volume on my phone to listen to a podcast and it would turn up the companion app notification sounds as well.

Fortunately these sounds can be easily turned off in settings, although wish they were off by default as they are redundant.

1 Like