Apple Watch HRM not working

Very excited this feature has been added. I have updated the app, installed it on my watch, and paired it with Zwift on my iPhone. However, I don’t see any activity. I gsee the two blank bars on both my watch and in Zwift and no actual numbers. The watch says “In Game”, but no activity is showing. 

Do you know if the green lights on the underside of the watch came on?

Did you actually start your ride or were you just at the pairing screen?


Hi Jon. Yes on both of those. I restarted both the watch and the iPhone and re-paired befor and during a ride. And uninstalled and reinstalled on the watch and re-paired, but still nothing. I see “in game” on the watch, green lights are on and the green running guy is on the top of the watch screen (to show that a workout has started), and still nothing:

On your phone, can you run the Settings app and go to Privacy->Health->Zwift and make sure you have granted us access to your HR data?   It should have asked you when you first connected the watch and tried to ride.

What you are describing is how it acts if you’ve not granted us access to that data. I just went and turned the slider off and now I just see the “–” for HR.   

That did it. It was on, but I uninstalled the watch app, reinstalled, granted access again, and all works well. Strange. Must have been a glitch with my settings. Jon, you are the man. 

Ok so I was having the same trouble and got it working on my phone following the above.

However, I cannot seem to get my apple watch connected to my iMac?

I tried closing the app open on the iphone ad restarting. even reinstalled the app for the imac.

any ideas?

Thanks, Jon! This fix is what also worked for me.

Having the same issue after upgrading to iOS 11.2.5, shows as paired but no greenlight under Apple watch and no Heartrate displayed on watch or in app. Have deleted and reinstalled app, permissions are set to allow heart rate.

Any help would be great!