Apple Watch 9 not connecting [SOLVED]

Hi, after weeks of working fine, my apple watch / Zwift connection is not working at all anymore.

On the Zwift App it appears as “connected”, but its not the case on the watch, bottom line is: theres no HR data being read.

Anyone had this issue before?

Apple Watch isn’t currently supported by Zwift (though it’s planned to change that) so while some people find it works ok, others don’t.

Not true, seems to be a bug, it was working until last week and there is even an apple watch app… i dont get it.

Sorry, but it is true. Support was withdrawn by Zwift a while back. Some people do still have it working, but you won’t get any help from Zwift themselves on it until they bring back Apple Watch as a supported device.

Zwift announced that support was coming this winter, (23/24) though it hasn’t appeared yet and yesterday’s layoffs will undoubtedly shake up schedules.

If you’re interested in a workaround while you wait for a fix, try using the Heartcast or Echo app with your watch. I tested Heartcast recently and it worked.