Apple TV Ethernet no longer able to connect with Zwift servers

My Apple TV is connected via ethernet cable to my router. Until two weeks ago this has been fine to connect with Zwift but now it says it can’t connect to Zwift servers. All other Apple TV apps work fine with Ethernet and if I unplug Ethernet cable, then Zwift works over wi-fi with it. However, I don’t want to rely on Wi-if with possible interference and lag.

So why all of a sudden does the Zwift app and only the Zwift app, not work with my router via Ethernet? Have some protocols changed that i need to adjust my router for?

Again, this has worked fine for the last couple of years by Ethernet.

Have reset the router and uninstalled and re-installed the app.


I was on Zwift couple of hours ago and use ATV connected with Ethernet.
All was fine here and not had any issues lately

Have you tried restarting the Apple TV too?

Yes, I have also reset the Apple TV

Is it only Zwift that won’t work on the Ethernet connection? Do other internet-using apps work on the ATV?

Uninstall & reinstall the app. It happens far to frequently on one of the devices we have here post Zwift update.

When you reset the Apple TV, did you just power cycle it, or did you do the factory reset?

Thanks but yes other apps are fine - see original post

Factory reset (annoyingly as lost all other apps)

Thanks but did that - see original post

Can you post a photo of the message you are getting? I use ATV with Ethernet and am not having any issues.

How old is it?