No other riders on Apple TV, help!


I’ve emailed swift support the below but heard nothing in a week so thought I’d ask here as well. Since I sent the below email, my Apple TV has auto updated again to the latest version.

I’m having some problems using Zwift on Apple TV App version 1.29.1(105318). Whenever I start a ride there are no other riders and the companion app won’t go into the riding mode. I’m using Bluetooth Garmin speed and cadence sensors and a dumb trainer.

So far I have tried:

  • Making sure Apple TV and app is up to date
  • Using both wifi and ethernet
  • Unloading and reloading the app
  • Uninstalling and Installing the app
  • Apple TV full reset and reinstalling everything
  • Many restarts of Apple TV
  • I have restarted my router
  • Apple TV is on the same LAN/Subnet and wifi/Ethernet as the mobile the companion app is on.

I have access to a PC and iPad as well so I have tried running Zwift from there and the problem is NOT present. All devices are sharing the same internet connection.

My internet connection is 1GB so I get 900mbps up and down and a ping less than 10ms. Speed tests confirm this is all ok.

When I am using Apple TV I am making sure I am not logged into Zwift on any other devices.

I don’t know what else to try to fix this now – can anyone offer any advice?

No other riders and Companion not connecting (no “Game” mode) implies network connectivity, not app-specific issues.

Could you describe your network environment in more detail please? Mesh networks are particularly problematic with Zwift.

Other things to check: ensure devices aren’t attempting to use both WiFi and mobile to boost speed (I believe Android and iOS have settings for this), ensure you don’t have blockers/firewall apps enabled, or if you do ensure Zwift and Companion are whitelisted.

EDIT - when you say “no other riders” - does the ATV actually SHOW your speed and cadence sensors, and does your avatar actually move on AppleTV?

The Companion app not working properly for many if you’re on iOS 16, especially iPhone 14.

As for no other riders while using the Apple TV, that almost always means you don’t have a network connection. Odd since you can download and/or update the app.

Do other Apple TV apps work properly? Have you run the speed test from the Apple TV using an Apple TV app?

Thanks for the replies. Something odd is going on but I have narrowed it down thanks to the above replies.

BBC i player, Apple tv updates, Zwift loading rides up to Strava - all works ok on apple TV. However, i installed a speed test app on the apple TV and that didn’t work (errored saying it had no network connectivity). So I dropped the firewall down to low settings on the router and both speedtest & Zwift started working normally.

This is odd because my network is very simple, 1 router and 1x 16 port gig switch. PC and Apple TV both connected by ethernet and are sharing the same firewall rules etc. Yet, the PC works normally and the apple TV didn’t.

I’ll have a play with the firewall permissions now and make sure all the required ports are specifically opened. I guess that will resolve it.

1 Like

Zwift does use some highly specific ports that need access, and it could easily be that your firewall has been blocking these.

1 Like

Yeah, but what I can’t understand is why zwift works perfectly on my Windows desktop. It’s connected to the same switch and router as the apple tv… I assume the same ports are required by zwift regardless of the device. So why would the behaviour be any different? :-/

“Your router firewall should allow all incoming/outgoing TCP traffic on remote ports 443, 3023, and 3025 all incoming/outgoing UDP traffic on remote ports 3022 and 3024.”

“ZC listens on TCP port 21587 and 21588.”

Saved those from some other thread some time ago.

Indeed odd that your previous setup works fine for Windows but not AppleTV.