Apple TV bug when choosing workout

Since the last update I’m unable to pick a work out on Apple TV… zwift crashes to the following screen…

Edit to add - fully updated and once the above happens you have to crash out and force stop the app… happens every time selecting a workout…

Does it only crash for workouts, or does it not let you free ride either?

It it won’t let you ride at all then see AppleTV problems with new update [1.13.0] [May 21 2021] - #88

It’s solely workouts crashes… Free rides & events are fine.

Tried on iPad and works fine…

My presumption is Apple TV doesn’t like the file structure of my workouts… but that would be a guess…

Sounds like a different problem then. I don’t remember anyone reporting this, but that’s not to say that I doubt you.

Does it crash for all workouts, including Zwift’s standard ones? Or just your own custom workouts?

Click on ‘Training’ and crashes… Goes straight to the screens in the image… Cant choose a workout, don’t get that far…

I have the same issue. Prior to latest update, everything worked as it should. Since the update, I am unable to do a structured workout on Apple TV 4k. I can do free rides. And I am also able to do structured rides using the Zwift app on my iPhone (and then mirror the screen to apple tv).

But when I attempt to load up a structure workout in Apple TV directly (by clicking on Training), the workout menu partially loads and then the app freezes.

I’m running v1.41.1 (72785) of Zwift on Apple TV: tvOS 14.6 (18L569).


Cheers for the reply Mark - Makes this a zwift issue over a set up issue.

@shooj / @xflintx is this a known issue?

I’ve just checked it in to our database, so it’s a known issue now! :wink:

In all seriousness, I haven’t seen anything like this specifically, though a few things come to mind.

Some basic steps that you can try that might help us learn more and also solve the issue for you:

  • try a different display with the Apple TV
  • uninstall/reinstall Zwift
  • reset the Apple TV

We are, of course, looking to see if any of these three steps will allow the issue to happen after the fact. Reproducibility and processes of elimination will always help us understand and solve the issue more quickly.


As an update, I have replied to the support email.

We have 2 users on this Apple TV device, one user (me) experiences the above with workouts, the other user can select and start a workout with no issues…

My presumption is, it reinforces my belief it’s not a device issue and it’s only been around since one of the last updates…

Another follow-up. I’ve been in contact with Zwift customer support directly. I’ve sent them a copy of my workout folder to see if they can replicate the issue I am seeing. I’ve tried an AppleTV reset and an uninstall-reinstall of Zwift, but that has not resolved the issue.


Hey @xflintx was there an update on this issue? Have you been able to recreate the fault from the files provided?

The issue is related to your custom workout files, though I haven’t gotten all the details as to why that’s the case.

Regardless, there is a fix identified and being tested. It will be released in a future update, so please keep your client up to date on your ATV. Hoping for sooner rather than later on that one.

Thanks for circling back around!


If I flatten the folder structure will that fix it as a temp measure?

I believe culling files would help, since I heard chatter about size of the folder running the device out of memory. Thanks to cloud sync, you could cull the number of files on something like your Mac or PC, log into Zwift on that device for a few minutes, log off, and then log into your Apple TV and that should hopefully help.

That’s more of an educated guess, though.

When is the new update happening solving the Apple TV upload to Strava issue!