ANT+ Windows 11 Broken

Hi,

Upgraded to Windows 11 and can no longer pair via ANT+.

Bluetooth still works.

There is no driver installed for my Garmin ANT+ dongle in windows device manager.

Any tips (apart from revert to Windows 10)?

Stick it in a different USB port to see if it comes to life. You can install the drivers manually but this shouldn’t be required. See if the dongle works on another PC to verify it’s not faulty.

Thanks Dave. Tried a different USB port, no good.

Plugged the ANT dongle into a different Windows 11 computer and the driver automatically installed and worked.

I can’t work out how to install the driver manually.

Does it show in Device Manager at all? Bear in mind it might be under a different heading than expected.

If so follow the steps here to overwrite/install the driver: https://support.wahoofitness.com/hc/en-us/articles/360021559679-Installing-ANT-drivers

If it’s not there at all, I’m out of ideas.

6 Likes

Thanks Dave. Just followed your instructions via that link and the drivers are now installed and working.

2 Likes

Dave, if you were here I’d buy you a beer. Went to the link and manually installed the drivers and I’m back in business.

3 Likes

Hello Dave,

I get “You are not authorized error” when viewing the link in your solution. Is there a way you can get me the contents of the page?

Appears that the page is no longer functional, at least without logging in anyway.

Try this: https://elitesrl.zendesk.com/hc/en-us/articles/360001020873-Dongle-ANT-driver-installation-Windows-

1 Like

Thanks Dave. That worked, appreciate your help.

2 Likes

have a look in the windows 11 non-windows update. you will find it under advanced options - extra options.
There an update file for ant+ dongles will appear

5 Likes

This worked for me, and I think is the ‘right’ way to do it. More specifically in Windows 11 open “Windows Update Settings” go to click “Advanced Options” then click “Optional Updates” on the option updates page there was a list of device driver update available including one for the Ant+ usb stick"

I just wish windows was smart enough to find AND install when I asked it to search for drivers in the device manager window…

3 Likes

this has just happened again since last game update, very annoying

I suspect something has changed regarding how Windows treats the driver which comes with the Zwift installer. As in, it’s no longer trusted. Seems to have been more prevalent since Windows 11 was released.

Can’t imagine why Windows would no longer trust software from Zwift. Maybe they’re on the forum here and see what happens on a monthly basis with the Bugdates. :grin:

Hey gang - we’re aware and investigating. It’s very likely that Windows 11 brought about some changes.

In the meantime - @Dave_ZPCMR kindly wrote up a helpful how-to on our forum so you can update the ANT+ drivers. Thanks Dave! :beers:

2 Likes

Hi Dave. Same issue opening the link. “unauthorized” Could anyone copy and paste ? THanks!

1 Like

thanks!!! thiis worked in 5 seconds.

Worked like a charm! :slight_smile:

Thanks Dave - This solution worked for me too with an unbranded ANT USB (i.e. not a Wahoo one). Pretty sure the missing driver problem did not occur immediately I upgraded to Win11 but maybe 2 weeks afterwards

Hi there, glad you’re sorted. Yeah I’m pretty sure it’s not directly related to Win11 as such (since the behaviour on Win10 has also changed), but perhaps changes to Windows generally that were brought in recently.