ANT+ Dongle won't find anything if using PC

I am new to Zwift. I have been using it for about 2 and a half weeks just fine and have been Enjoying it.

Today, all psyched up for a zwift ride, when trying pair my power meter to Zwift the ANT+ symbol in the top left just showed an exclamation mark and it won’t find anything (Vector 3 power meter or HR monitor) to pair. I have tried all my USB ports and have restarted the computer multiple times. I have also unistalled garmin express just to be sure there is no interference.

Finally I installed Zwift on my laptop and it all paired fine (so not a dongle malfunction). But the laptop is slow and not ideal for gaming. Zwift was laggy and jumpy when moving… So need it working on the PC! So gave up after an hour of troubleshooting feeling really annoyed that I’m not able to ride (young kids in bed so obvs can’t ride outside and leave them on their own).

It’s almost like Windows just suddenly decided to block Dongle or something. Maybe Windows defender is being over zealous! HELP!

Might be a driver issue. Have a look in Device Manager and try reinstalling the driver for ANT+. If you don’t know what I’m talking about, try Windows Update for starters and see if it has any optional updates.

Thanks mate. Looks like you are spot on. This unknown USB device appears when I plug in the ant+ dongle. devMngrSnip

Now to figure out how to fix it. I have already deleted the driver and the plug it in again. But same thing appeared. Also tried clicking update driver. But it just says windows couldn’t find one. So frustrating!

Did you try Windows Update? That might find a driver.

I’ve used both a Garmin branded ANT+ dongle and a cheap one I bought on Amazon - more or less with equal success (and challenges). I found it was too unstable for my setup without a USB extension (and I tried a couple of those before I settled on one that is powered). Using that and either of the dongles, I had pretty decent stability on a Windows PC. With correct positioning of the dongle to the trainer, I got to less than one signal drop out a month (and typically those were not terrible - i.e. did not have to recycle anything, it reconnected on it’s own relatively quickly). I’d buy the cheap dongle, a decent extension and then spend some time working thru where the dongle gets the most stable signal for your trainer.

What ANT+ dongle do you have. They are not all created equal. One would think they should all work, but that is not the case. Some do not sample as often or have other issues for example. Some will work in one computer and not another as well. The dongle that I’ve seen people report to consistently well is the ANSELF branded one. Some of the others not so good. There is a lot of discussion of this on the forum. ANSELF is the recommended dongle by ZwiftInsider and their testing (along with a couple others that are more expensive).

Mine did that once. All I did was open up the properties of the “Unknown USB Device” and reinstall the driver from there. Everything has been fine ever since.

Thanks for all the ideas.

It’s a ‘CYCPLUS’ Dongle. Currently searching the Web for a download able driver. No luck with Windows update.

How about if you delete the device via Device Manager, and then re-insert it again?

As others have indicated, the symptoms you described in Zwift mean the ANT+ antenna is not detected by Zwift. This happens to me once in a while (using a Garmin dongle) after booting; it’s as if the driver and device (dongle) missed their handshake and are thereafter ignoring each other. I simply pull the dongle out and put it back in; this forces Windows PnP to reconnect the device, and works every time in my case.

I recently also had driver issues, but mine is a Garmin dongle, and I fixed it just by reinstalling Garmin Connect. Wort a try probably

Sorry to say, but CYCPLUS is one of the ANT+ dongles with known problems. I started with a CYCPLUS and had lots of problems. I returned it to where I purchased it (Amazon) and bought the ANSELF and all works great. You can search for drivers and never find anything that solves the problem. From what the collective knowledge on the forum shared, the CYCPLUS dongle is lacking the protocol to check connection on a frequent basis. It drops or fails to connect often.

Really appreciate all the comments thanks lads.

I briefly thought I solved it. I unstalled zwift and the driver and installed them all again. I also removed the USB extension cable and plugged the Dongle directly into the computer and I worked for a couple of days. And then… Same happened again out of the blue. So…


I’ve ordered a different Dongle.