ANT+ dongle not always detected. Windows 10

Since the most recent update, zwift doesn’t always detect that my ANT+ dongle is connected. As in, it has the yellow warning sign my the ANT + icon.

I have tried each usb drive, with and without the USB extension. My drivers are up to date. Twice, once successfully connected via ANT+, I tried to start I ride for ANT+ to drop out again and then Zwift won’t detect the dongle again. Once I restart Zwift, (sometimes twice), it works and I tend not to have problems.

Hi @Josie_Park_ICC

Welcome to the forum,

I assume you use a windows Pc. Make sure you don’t have the garmin app installed or any other program that may use your ANT+ dongle.

1 Like

I don’t have any Garmin Express installed. I also tried on my other windows 10 laptop, and same problem happened. I had to restart Zwift before my dongle was detected.

It can be that your dongle is on the end of its life.

1 Like

Thanks. I’ve already ordered a new one so hoping this resolves the issue. It’s just odd that it only started happening after the Zwift update. Literally first ride after it updated, Ant+ dropped out just before starting a meetup. First time it’s ever happened,
so it seems a bit of a coincidence if it’s the dongle that decided to stop working at that point!

Hi @Josie_Park_ICC, did you get a new dongle and did it work straight away? Windows 10 has just updated for me and straight away my Ant+ dongle is no longer being picked up! I find it hard to believe it is coincidental!

Regards
Bruce

Hello guys, I normally don’t post, but I just solved this problem on my Windows 10 laptop. [Tried to embed images but the website won’t allow me.

Go to Windows Update
Click on “View optional updates”
Select the one to do with Ant

This fixed it for me. I tried to uninstall the driver and that didn’t work.

I use a cheap Amazon dongle and it’s not the dongle.

2 Likes

Superb! thanks from Portugal… You bring my USB ANT + to life

1 Like

Thank you so much for the solution!
I was having no luck finding answers and was getting so frustrated.

1 Like

Thx a ton! Just upgraded my PC to win 10 due to zwift indicating no more support for win 8.1 and older.
When i started zwift the usb dongle did not work properly. Thx to your instructions i was able to get my ant+ dongle running again without much hassle.
I am really happy that i found your instructions quite early in my search, thanks again, much appreciated!

I had to reluctantly update to win 10 (very annoyed with zwift) but win 10 wouldn’t recognise the ant2 little dongle.

After a few windows updates it recognised there was a driver needed and I eventually got windows update to install a driver automatically.

I could not do this any other way via a direct driver download etc…

So thank you for the above tip.