ANT+ Update

As I have an FEC Trainer and an Android 10 phone which is going to become the norm as people upgrade their Android phones, you are going to be locking anyone using Android 10 out of using their phone if they need to use FEC, but fortunately for me I have been using a computer, but those that don’t will most definitely be disaffected! Which incidentally locks me out of being able use my phone as an alternative if my computer was to suffer a significant enough failure.


Phone xiaomi mi9 android 10 + otg + ant+ dongle
Garmin spd- ble work, ant+ not work
Garmin cad- ble not work, ant+ work (breaking connection every few seconds)
Garmin fr245 transmits heart rate (breaking connection every few seconds)

didn’t work for me

all the sensors showed up as ant+ until it found my controllable trainer (bluetooth) then the ant+ power meter and cadence sensors all disappeared exact for the ones that the trainer was broadcasting.

Ant+ heart rate seemed ok.

still no resistance via bluetooth for the zumo so wasn’t really able to test it - will have a go on my flux when i get a chance but can’t see the pairing issue being any different


First, I’m glad it works at all, because it’s significantly less headache inducing then trying to skip commercials on YouTube when in the middle of an interval.

So far, I’ve found one consistent bug, when I begin running, everything tracks accordingly, but when I stop, my character continues to keep running at the same pace. The cadence will drop to 0, but the pace will remain and seems to translate to continued running. When I begin running again the pace will again change dynamically with my speed as I adjust the treadmill, but the character won’t stop running after I initially start.

I capture the activity at the same time with my Garmin 735xt and it will auto pause at these points.

I’m using a Garmin foot pod bought new early 2019 with a Samsung Galaxy S10e while also recording heart rate with a new wahoo tickr X, also connected over ant+.

1 Like

What do you mean by this, how can you blame this regression in your app on 3rd party android libs? I am on android 10 on a Samsung s10e. It was working on v 1.0.43801. Is it now broken on 1.0.44401? That would not be an improvement.

Going to hold off updates on zwift till this is stable.

I’m not sure how much effort it would be to implement the FEC support, but I assume it is also part of the 3rd party Garmin libs?
If that is the case, it would be great if it can be implemented. For some people, ANT+ works better, for some Bluetooth; and when a trainer comes along with bad Bluetooth implementation, at least one could then fall back on ANT+.

I still need to test the ANT+ support on my tablet, but luckily all my sensors are dual bluetooth/ANT+ anyway. So I will likely end up using whichever seems to have less dropouts for me.


I’m chuffed that these other features have been added to ANT+ took me a while to figure out why I could only see my HR strap (which works perfectly btw). Shall check if my powermeter works tonight, I would however like to add a ‘me to’ to the FEC support please.

+1 for FEC over ANT+ on Android!


Hi Henk!
Yes, FEC support is part of the Garmin libs. The effort depends a bit on how broadly we want to support FEC - for example certain vendors (like Saris) have their own flavors of ANT protocols, which require more special code, testing, etc.
Thanks for sharing your thoughts.

Hi Richard,
Things have stabilized. And you can now use Android 10 for ANT+ .
(Limitations at top of thread)

And yeah, the regression was my fault, not Garmin’s. I’ll own that :slight_smile:
Thanks for the feedback and for riding Zwift.

Focus on the standard FEC - that might give the trainer vendors a much-needed push to adopt the standard :wink:

Unfortunately the latest update refuses to install on my tablet, so not sure when I will be able to test the ANT+ support.

Successfully tested out using ANT+ with my Garmin footpod and broadcasting HR from a Garmin 935 watch… Had one error message pop up about some search object on the pairing screen but it seemed to work okay for my 20 min run. Using an Samsung S7 edge with android Nougat.

Thanks for turning this on and saving us having to go out and buy new Bluetooth accessories!

o for oarsome!

1 Like

has anyone managed to connect a controllable trainer via bluetooth and then a different power meter and cadence sensor via Ant+? I can’t do this currently

Samsung Note 9, S3 Tab & Sony Xperia Z5 (7.1.1) updated to latest Android version.

Bike ANT+:
HR - Confirmed I am alive
Power - Detected my Neo OGPower
Cadence - Connect to Neo OG Cadence
Smart Trainer - Nanoo Nanoo
Speed - Nanoo Nanoo since Power is present.

Run ANT+:
HR - Phew still standing
Cadence - Footpod detected
Treadmill Speed - Follows footpod calibration

So most of the required sensors are detected. Its good to go even with the few minor quirks.

1 Like

did you pair the neo as a smart trainer via bluetooth with that?

Thanks for posting your results!
Yes we left some ANT+ status/error/warning messages in the code.
We’ll remove them down the road, but figured since the feature is still in Beta, the extra messages could help us and customers diagnose issues.

It’s very helpful to see all these posts on various Android device / Ant sensor combos.
We really appreciate the feedback!

1 Like

Regarding “latest update refuses to install” could you please email with all the details?
Especially if Zwift worked prior, and now doesn’t - that sounds like a serious issue, and support team can likely sort it out and escalate as needed.
Sorry for the troubles.

1 Like

It wouldn’t detect the smart trainer even if BLE is present. Bummer.

seems like one step forward one step back with the android app - it’s a shame, i’l like to use my android tablet but guess i’ll stick to windows

Hello - I am still having the Android 10 Ant+ HR monitor problem, from the discussion above it seemed like it was fixed. I have a garmin vivoactiveHR and LG G7 one. It used to work fine, now it doesn’t. I can pair the watch to zwift but my HR doesn’t show up while riding (says there is no signal).

If I am mistaken and you are still waiting for the Garmin libs to get HR back up please reply. Also, if you want any other info to help troubleshoot please ask and I will provide whatever you like.