Ant+ overrides bluetooth

Hello fellow zwifters!

I have a bit of a problem. I have this new tablet (samsung galaxy s6 lite) wich I want to use for zwift.
I’ve read many good reviews about it. However i have a problem with ant+.

Ant+ is native in the software and thus can not be disabled. The signal on the ant+ is just to weak to make a stable connection. While bluetooth on my phone works like a charm.
At this point I really don’t get why anyone would choose ant+ in the first place.

I disabled all other interference, put my wifi on 5ghz, put the tablet right next to te trainer. But still the signal drops.
Heart rate is the most stable one followed by cadance
But power and controlled power (smart trainer) loses signal every couple of seconds.

I use the wahoo kickr snap, the wahoo tickr and the wahoo cadance sensor.

I hope anyone can help me with it.
Thanks in advance!

Hi,
When you enter the Zwift pairing screen and select your trainer (and other devices), do you see a pop-up menu like this?
https://images.app.goo.gl/pmJiGefmqo9QpykW9

You can see that for the paired the device there are options to pair via Bluetooth or ANT. Icons for BLE and ANT are on the right of device name. You should be able to select which method you prefer.

If both ANT and Bluetooth are on and being broadcast from your trainer, sensor, and heart rate monitor, you should be able to select your preference in this pairing screen.

Hope this helps.

2 Likes

Unfortunately they don’t show the bluetooth ones. Only ant+ in the left hand corner I can see both ant and bluetooth pulsing. But Ant+ icon seems to be larger.
Thanks anyhow!

Can you post a screenshot? From your description, it sounds like you are describing the initial pairing screen. That fact that both are pulsing is a sign that both are working with Zwift. You need to go one step further in to change which method is being used for each device connected. The place to change which method is used is in the device pop up screens that you get when you double click on the desired device (trainer, heart rate monitor, or sensor). You will then see a list with your pairing options which will include both ANT and BLE and you can choose what you prefer.


You should see a pop-up that looks like this. This is wear you pick Bluetooth or ANT connection.

3 Likes

I don’t get the option to use bluetooth. Only Ant.

Found it!
You first need to open zwift and login until you get to the pairing screen. And only then plug in the trainer.
Such a simple solution. Who would’ve thought…

Thank you for your help! Really appreciate it.

Merry zwifting!

2 Likes

Glad that worked out for you, happy Zwifting!

Hello

I have read the topic,because I have a similar problem.

I click on the power device (buttom left top) and have two Ant+ sources (with "no signal’) an no bluetooth source. Bluetooth is switched on,but not connected to the Tacx Flush 2 trainer.But if i have connected before starting Zwift, it is the same problem.

How can I connect with bluetooth from my android Samsung A51 smartphone to the Tacx trainer?

Tanks for your help.

Hey Michael

Have you tried my solution?
First start zwift on your device up untill the pairing screen. Only then plug in your trainer and other sensors.
Hope it helps.

Hi Janko,

Yes i several tried the same: start swift, only click on the trainer (top left) on the pairing screen,the pop up window show me two Ant+ sources (with “no signal”), but no bluetooth.

That is your discribed solution right?
Or do you anything else for the bluetooth signal?

You must allow Zwift to have Locations permissions or Bluetooth doesn’t work. This is true for Android and iOS.

Go to Android Settings > Apps > Zwift > Permissions > Locations .
Give Zwift permissions.

Why? Android lumps GPS and Bluetooth radio functionality under the Locations setting. Zwift doesn’t need or use the GPS radio - it does need access to the Bluetooth radio so it can find your Bluetooth trainer.

2 Likes

Sometimes you have to wake up your device.

Step 1: open zwift and log in
Step 2: go to pairing screen
Step 3: plug in your trainer
Step 4: cycle a bit to wake it up
Step 5: click on the pair trainer button.
Step 6: bluetooth should show up.

If it still doesnt work, let me know. We’ll figure it out :slight_smile:

Yes that is the solution :slight_smile:
I always had GPS and Bluetooth switched on,but GPS had no permission,what i didn’t realise. So I gave Zwift the location permission and now i have bluetooth.

Thank you for your help!!!

1 Like

So glad I found your solution on the forum. Have been having the same problem the last few days, so frustrating. But now it seems to work, Can’t believe it’s this simple.

Hi, I got an Lenovo Tab P11 Plus (Android 11) tablet and a Elite Direto XR-T trainer.
I could install Zwift on my my tablet but it didn’t connect to the trainer.
When It try’d to connect it showed the icons for Bluetooth and Ant+.

On my Iphone 12 the Zwift app found the trainer on the first try.
The difference was that the Iphone 12 didn’t show the icon for Ant+.

The solution I found was to to install the Ant+ Plugins Service via Google Play.
After that Zwift found the trainer.