ANT+ Not Showing In Device Manager

I’ve been using an ANT+ dongle with no trouble for months. I had some Zwift issues yesterday and decided to do a re-install of Zwift. Since then my Windows 10 laptop doesn’t see the ANT+ dongle.

I have confirmed the dongle is ok by using it on a different laptop.

In device manager there is nothing for the dongle. Windows doesn’t even give me the little ‘bing/bong’ when I plug it in.

I know this isn’t a Zwift issue (apart from maybe the unistall/re-install causing the problem) but I thought somebody might have a clue what I can do. I have tried to uninstall and re-install Zwift twice more just to see if it would somehow fix it but it hasn’t.

Any thoughts or ideas of what I can do would be much appreciated!

Tried all your USB ports?

Yeah. All three of them.

Are you using an extension cable? If so, try plugging it in directly to see if that picks it up. I can’t see why your issues with Zwift would prevent it showing up in Device Manager. Tried scanning for new hardware?

It’s definitely a laptop issue not Zwift. I’ve tried it in all the USB ports with and without the extension.

No idea what to do next!