ANT+ FE-C Connection dropping after 5 min

Hello. Does ant tester or any other app regarding ant+ drivers needs to somehow be enabled to run all the time in the background for ant+ connection on android using otg cables and ant+ receiver to work?

Today I again managed to connect ant+ fe-c and it worked flawless (even erg mode and everything) for 5 minutes then all connections were dropped.

Attaching pictures. The first one is where everything is connected (it worked in the game when pedaling as well, avatar was moving, selected workout worked. Erg mode ok smart trainer worked as well. For 5 minutes untill everything was disconected). The second one shows no signals.

Just as a thought… I am not a TACX user, but I read a very detailed review about one of many TACX models, and that review showed that the unit has a battery compartment with two AA batteries in it. Apparently, some of the electronics runs from these batteries, and for some reason I have it left in my head that it was ANT+ transmitter. Is there a chance that you own one of these models, and your battery are almost dead and require replacement?

Thanks for your thought. I am using Tacx Flux S Smart trainer and I can not find anything on the internet about AA baterries in it… Ant+ if used on a laptop works without issues, so I doubt it is trainers fault.

The flux has no battery related issue so it’s not that.

What’s the distance between your trainer and the Ant+ dongle? This is a very common feature. Every installation I’ve done for others I’ve used an extension lead and sat the dongle underneath the trainer. My own experience when I started was that I had no such issue without an extension until I’d been Zwifting for many months and then one day I lost signal with the trainer. It would come and go. Fitted an extension and never had it since.

I have owned a Tacx Flux S and never had connectivity issues or found a battery. Recently upgraded to Stages SB20 working with a Samsung Galaxy S2 tablet. All working fine until a few days ago. Now ride begin ok using BLE apart from ANT+ for HRM (Garmin) but fail after a certain amount of time. Devices still connected but no signal. No recovery after that so have to bail. Something has changed. Please resolve…I am a long time but now very ftrutrated customer. Laptop use doesn’t have this problem so have to surmise this is Swift Android related.

The distance from the ANT+ receiver to the trainer is less than 1 meter. Bluetooth works fine at such distance. When using the same ANT+ receiver on laptop at the distance of at least 1,5 meter (definitely more than when using a tablet) the ANT+ signal works and doesnt drop out.

The issue you have David could be the new update which appears to have affected some users using Bluetooth. This is being looked at.

For yourself Tadej I’m not so sure. Can you post the details from Zwiftaliser onto here so we can see what the issue was.

I am uploading Zwiftaliser photos here. I am also getting a new OTG cable (they are cheap anyway) to make sure OTG cable isnt the reason for the issue.

Stuart. Just reporting back and then dropping out of debates here. Seems fixed as at yesterday, for me at least, following an update - successfully rode for 80mins for the first time since end of last week without a dropout / loss of signal report when connected to my Galaxy Tab S2 (not mentioned in the list of devices that are good / ok to run Zwift BTW - mine having the seemingly essential Snapdragon processor not the Exynos processor variant that also exists). Frustrating but had a fallback using laptop that seemed unaffected by these Bluetooth issues. Glad things are sorted. David

This one is obvious but I have been there. Some mornings one cup of coffee is just not enough. Make sure it is plugged into power and awake. You might need to start pedaling to wake up your trainer. Some bike trainers self-generate power like the Tacx NEO. Pedaling should wake up the trainer.

After extensive research that I had to do on my own, I managed to figure out the following.

The reason for Ant+ connections dropping out is, that my device (check attached pictures from ANT Tester app) loses the connection to ANT+ receiver. For example, on the first picture below you can see that built-in firmware is recognized - “AJK”.07RAF". This screenshot is from the moment when I sucesfully connect power meter, cadence, heart rate and controllabe in the game.

The second screenshot is few seconds or minutes later, depends on how lucky I am with the connection. The dropout can happen after seconds or after minutes. The screenshot is taken immediately after I get “No signal” message in the game menu → paired devices. On the second picture you can clearly see, that next to the built in firmware there is written “No”. I am pretty sure that is the reason I lose connection to my ANT+. How can I force my tablet to keep the ANT+ receiver powered all the time? How to force the device to not lose the connection to ANT+ receiver connected via OTG cable?

Bump. Still an issue.