ANT+ Dropouts


(Jerry Weiss) #1

Anyone having trouble with ANT+ dropouts read below.  Zwift has been no help, but StagesCycling.com gave this advice and IT WORKS !!!

 

Routers transmit on the same 2.4GHz frequency as ANT+ (which is the power meter uses to communicate with the head unit), and can sometimes overwhelm the power meter signal. When this happens the head unit will not be able to receive the data and will display zero values, and then will return after the interference has passed. 

 

There is an effective solution for this, which involves a quick adjustment to the broadcast channel of the WiFi router. Within the 2.4GHz band, there are even smaller channels present, which are numbered 1-13. Generally routers will broadcast on channels 1, 6, or 11. The ANT+ signal from the Stages power meter is broadcast on channel 10, which overlaps quite a bit with channel 11. Thus, if there are networks present on channel 11 it could cause interference problems. The easiest solution is to shift any of those networks on channel 11 to channels 1 or 6 to avoid overlap. Below is a diagram which offers a visual rendering of this signal overlap.

 

 

 

 

This is a fairly comprehensive guide on how you can make this change: http://www.pcadvisor.co.uk/how-to/network-wifi/how-change-wi-fi-channel-3325316/


(Tim Camden WBR (C)) #2

This is good info to know.

I have not had this problem yet but it is good to have the background info.

I would like to point out that this is not technically a Zwift issue.

Thanks Jerry.

 


(Stephen Higgins) #3

I have a Wahoo Kickr Snap. I’ve tried many things now. Turning my fan off, turning my bluetooth speaker off, putting my phone and watch in airplane mode, unplugging my hdmi and turning my external monitor off, bought an extension cable, bought another extension cable with an amplifier, bought an extra power supply for the cable, turned the whole setup round 180° like it was back in December when it was working.

The weird thing is I did quite a lot of Zwifting at the end of last year with very few problems with the exact setup I tried this morning, but right now my setup is unusable.

Seriously considering an Apple TV, but I do wonder whether I’ll end up shelling out and still get problems.

Having read this post I’ve gone in to my router settings and set it locked to channel 1, but it looks like it was on channel 6, so I’m not convinced I’ve solved it.

More testing tomorrow…


(Jerry Weiss) #4

Good luck. I changed from ch11to 3and it solved my problem. Theres an android app called wifi analyzer that shows all close by transmitters and what channel they are on and how string they areat your location. Might be helpfulin choosing a ch


(Jerry Weiss) #5

Maybe your power meter broadcasts on ch 6; if it’s not stages