Android set up


(Richard Green) #1

I’m new to Zwift and only have Android. I’ve downloaded the app but can’t see where to add the smart trainer (tacx flow t2240). The option just does not appear?


(Jesper Rosenlund Nielsen [ZwiftHacks]) #2

Press the ‘Power Source’ button and let Zwift search for your trainer.


(Richard Green) #3

Doesn’t find the unit, just keeps searching


(Tan Edwin(Bike Kaki) ) #4

I had the same problem, kept searching…I am using the following.

Tablet : Lenovo YB1-X90L, Android 7.1.1
Trainer : Elite Direto
Heartrate Bluetooth sensor : Geonuate

Any solutions?


(Vincent W.) #5

Hey Richard, are you trying to pair your trainer via Bluetooth? If so have you tried our troubleshooting steps?
You can read up on them here: https://support.zwift.com/en_us/i-can’t-pair-my-bluetooth-devices-(cycling)-S1DW01ZBQ


(Per Johan Broden) #6

I am having the exact same problem. Shouldnt the image above be showing “Heart Rate” and Contollabe also? Or should I choos Power meter when trying to connect to my Kickr snap via bluetooth?


(Tan Edwin(Bike Kaki) ) #7

It will only show on the subsequent window after the app detect your trainer.


(Per Johan Broden) #8

I see. So when the app detects the trainer the choise "Controlable"will show? But why doesn’t it show? The trainer works perfectly with the Wahoo utility app and I have restarted it (unplugged the power) so it should not be connected to anything else, it should connect to Zwift. I read that it moght take a long time to connect, should I wait for minutes before the “Controlable” option is shown? I am loosing free days here, I wanna try zwift out to see if I wanna buy it or not. :slight_smile:


(Tan Edwin(Bike Kaki) ) #9

Once you see this page,

You choose power source (smart trainer) or speed sensor (normal trainer) to pair your trainer.

Once it detect your trainer, it shd detect in this window.

Once it detected and showed your trainer in this window, click ok and it will show the following screen.

Just paired your heart rate monitor and u are good to go.

Hope this help.


(Per Johan Broden) #10

Great Tan Edwin! That helped. My kickr showed up when I chose Power source and then I was out and pedaling for the first time in my life on Zwift! Super thanks for the pics and explanation. :+1::+1:


(Tan Edwin(Bike Kaki) ) #11

You are welcome and enjoyed your ride…


(Sententsiya Sport) #12

To find the device, turn on geolocation on your smartphone :ухмыляющийся: