Android app losing Game tab during activities

Anyone else having this issue?

Sometimes closing app or even a phone restart resolves, other times these still doesn’t resolve issue.

this has been happening to me, too.

i uninstalled the app and reinstalled it and it happens less frequently, but i am still seeing it.

i also get kicked out of the game tab sometimes when i finish the first lap on a course.

I got the same issue. First I through it is due two wi-fi networks I got at home but later on when I removed one from the phone it has not resolved the issue. So now sometimes during the workout or group ride I realize I am out of control as I can’t reach my PC keyboard easily.

Very interested in resolving this issue.

Same here. The app returns to home screen several times while doing a group ride. I had to restart the app every time to go to the game tab again.


Yep, same here. doesn’t seem to make any difference if the app is open before or after starting a ride. I’m using the same Wi-Fi network and not using a mobile signal (there is none). It’s worked perfectly well prior to the last week or two but is, at best, intermittent, and often unusable. I’ve tried restarting the app a number of times but it makes no difference as to whether it connects to the “Game” or not. Frustrating as I spend more time fiddling with the phone than looking at the ride. Any news Zwift people?

Still happening here, Game tab refused to load at all tonight. Numerous phone reboots and lots of swearing during my ride.

Galaxy S6 fully up to date with all updates, patches etc.

Please investigate!