After Reset Password can't log into app

Haven’t been on my trainer in a while. Tried today to open up app and it would not take my password steps taken:

  1. reset password
  2. Used reset password to log into companion app (works)
  3. log into app on mac won’t take my password
  4. deleted app and reinstalled - still not working

Anyone please help. Spent the last 15 min on this an no results. the Zwift Chat function is not helpful for this matter.

The app has a repeating UI/UX quirk where it won’t accept a typed username or password, resulting in a log-in error.

The solution: reinstall app (which you’ve done), add existing user, DO NOT TYPE USERNAME AND PASSWORD IN.

Instead, go to a separate NotePad (or similar) app, type your username and password on separate lines, then copy-paste them into the appropriate fields in the Zwift app.

100% of the time, this fixes the issue for me.

EDIT - if on a PC/Mac (not an iPad/AppleTV), you may have to delete whatever folders Zwift has left installed to completely remove all traces of your existing user profile.

1 Like

Tried no dice. super frustrating

  1. it pre-populates my user name so deleted that
  2. copy and pasted user name and password
  3. same issue won’t accept it - not even an error just won’t work
  4. delete app and reinstall
  5. Again app on mac pulls up but prepopulates my username
  6. repeat step 2-3

now 30 min into this. Help please?

The fact that it’s pre-populating your username is part of the issue.

Question: are you getting a completely BLANK login screen with no users pre-populated? (similar to the one below)

From that screen, clicking “Add existing user” should yield a screen with BLANK fields. If not, either your system is auto-populating fields (no good) or your user profile is still saved on your system. You need to delete that from the system entirely. (not sure how do on Windows/Mac - I’m using a tablet that nukes all user data if uninstalling the app)

1 Like

Hey!

Glad you resolved it! You typed that just as I was typing a follow-up: indeed, the folder where Zwift was storing your user data needs to be removed or the newly reinstalled app will just keep trying to pull old profile data.

Oups tried to edit.

I finally got it to work steps taken

  1. opened up app with prepopulated username
  2. entered password with user name blank
  3. then copy and pasted user name and password
  4. let me in

I was going to say that is a pretty significant UI/UX bug.

1 Like

ok so steps are in case someone else needs this I burned 30 min on this)

  1. Delete App
  2. Delete folders
  3. Reinstall App
  4. Delete Username
  5. Enter password wihtout user name in it
  6. Now with both username and password clear do the below:
  7. Copy and pasted user name and password

I was going to say that is a pretty significant UI/UX bug.

thanks for your help! @Otto_Destruct

1 Like

Great news that this worked for you, Ratna.
To help others find what worked thanks to @Otto_Destruct, you can select the most useful of his responses and tag it as ‘Solution’. That will add the relevant info just below your opening post.

1 Like

yeah that is great but what about Zwift fixing the bug?

Hi @Ratna_Warouw

Welcome to the Forums!

It’s hard to say if the issue you encountered is a true Zwift bug or if it’s more an issue with macOS.

My first thought is that you’ve got the email and password stored in your keychain, which is an encrypted container that securely stores your account names and passwords on a Mac. I’m guessing you’ll need to clear Zwift data out of that, which generally takes more than deleting folders and re-installing Zwift.

For more information on managing your passwords using keychains on a Mac, please see this related Apple support article​.

I am currently experiencing this bug under Windows 10.

Took two weeks off due to the flu. Can’t remember my password when I try to login, so I reset it.

I have entered the password perfectly 10 times and still cannot login to the app.

I’ve verified my inputs on both app and website and they are identical. I just logged into the forums with this password to post this.

Edit:

I’ve uninstalled the app and reinstalled, as well as clearing all edge cached data.

My email is still remembered in the app.

How the hell can I clear your stupid app cache so I can login? What kind of moron uses Edge as an authentication storage mechanism??

Any fixes to this issue? I’m facing the same.