After march 2021 update no ANT+ device found for garmin heart rate monitor

After march 2021 update issue with connecting ANT+ Garmin heartrate monitor

Battery is new and it connects instantly to Garmin Forerunner 210

When clicking the heartrate monitor ICON in the Zwift app it starts SEARCHING but finds NOTHING

Before the update is worked fine

What to do?

My hrm device is a HRM3-SS

Hi @hans_gorter, welcome to the forums. What device are you running Zwift on? Please list all the details of your setup.

Do you connect your trainer via ant+ too?

In use my Samsung A70 android 11 for running Zwift which I mirror on my tv with google chrome cast

I use the original garmin forerunner 210 ANT+ hrm with strap

I use a wahoo blue sc bluetooth & ANT+ supported speed and cadance sensor

Before the march 2021 the garmin hrm was running with Zwift
And my garmin hrm is only 2 weeks old and is found instantly by my garmin forerunner 210 which is also 2 weeks old

  1. what I did is delete the ANT+ files from my phone and reinstall the files. Without success

  2. Next I deleted Zwift after the update and reinstalled Zwift without success

  3. Next I installed Zwift on my wife her phone which is also a Samsung A70 android 11 again without success

With all these steps I got support from Zwift.
The steps I made I did on my own because nobody could tell me what to do and support kept always saying my hardware is not good and there is nothing wrong with Zwift
Getting to the point of pure frustration that I better quit my Zwift membership
This is now already going on for about 5 days and no solution.

They only wanted my login files but of course I deleted Zwift and reinstalled Zwift so I could only sent the login files from after the march 2020 Zwift update

So I proved with 3. That it is not the phone
I proved also my devices work 100%

So it is Zwift which is not functioning properly, something

After the update I experienced more problems
First with my login the password for the app which is the same as the Zwift website seemed to be wrong???
So I logged in with my Zwift app password on the Zwift website and yes that worked.
Then I changed the password and trier loggin in to the Zwift app with the new password
So I had to login pressing EXISTING USER
And that worked

After the login Zwift didnt find any sensor whatsoever so I restarted the app and then only the wahoo blue sc speed and cadance sensors
On bluetooth 4.0

Thats all

No I use a dumb trainer and it had no sensors

Read my other reply for everything

I dont use a smart digital trainer in the first place because they are all very unreliable and break really quick or they are too expensive

Why because training indoors is for cycling out doors and it is much more fun to cycle out doors

I am not going to pay €600 up to €2000,- for a smart trainer which simulates hill climbs it doesnt make sense the prices are too high for that and you only get frustrated when you throw away your money on crap. I get the idea Zwift is crap also reading all the Zwift problems.

Fact there are much better programs around like Rouvy which are bases on augmented reality
I wanted to try out Zwift and its ok but really I am only on Zwift for a month now and Zwift sucks, yes it does

The only fact why I choose Zwift is the lively colors so you dont get bored and the computer game apearance which looks funny with lunatic sounds which are funny somehow
Just a dumb game which is more then just a dumb game if you take it a bit more serious

But fact is I dont take it serious anymore I rather go cycling outside which is so much more fun mountainbiking or speed cycling that is fantastic outside

I am starting to hate indoor cycling already

Reading the above I think you’ve isolated the issue more towards your own setup rather than Zwift but after your berating of Zwift I’ve lost any inclination to offer any further assistance.

You’re better off cycling outdoors given your opinions


That is a lot of devices and signals flying around, probably getting interference. You can check a log file in to look for interference.

I’ve also seen that the Garmin app can steal the signal even if the app isn’t running, if you have a Garmin app on the phone try Uninstalling it and then open up zwift, I would also turn off the watch and your partners phone.

1 Like

Well Mike I am glad with your advice hopefully it will bring me a bit closer to get it working again

Thank you for your advice