2013 RideSense Cadence/speed sensor not found


(1 Legged) #1

I saw a post about this from earlier this year but it neither showed solved or appeared to allow further comments.

I have a functioning Giant RideSense Cadence/Speed sensor from 2013 that I would like to use in place of a buggy power meter. Though I can pair it with my Garmin, it does not show up under cadence sensors in Zwift. Please advise.


(Terry Cheng) #2

Connecting via Bluetooth or ANT+? If Bluetooth, make sure it isn’t connected to the Garmin (while on) s Bluetooth can only connect to one thing at a time.


(1 Legged) #3

Sorry, this is an ANT+ device.


(Paul Allen) #4

What devise are you running Zwift on (iOS, PC, Mac, or Android)?


(1 Legged) #5

I am running it on a Windows gaming tower. All the latest specs and current versions of Zwift and all drivers, etc. I have the ANT+ dongle placed just inches from the sensors.


(Fnu Ashwani) #6

While there can be several reasons causing this issue, I would advise you to visit the following articles for all the basic troubleshooting:

Zwift can’t find my USB ANT+ dongle
My ANT+ Signal is Dropping

Both of these articles cover up all of the potential reasons that may be causing this issue, so please give them a read.

If you are running any other cycling app in the background, make sure to force close it, and turn off any other cycling device as well. Follow all the trouble shooting steps one-by-one as mentioned in the articles.

If your issue still persists, open a support ticket with us, and we’ll get back to you!


(1 Legged) #7

Ugh. I’ve gone through all of this and ANT+ is an issue in other areas but I am specifically asking about why the Giant RoadSense speed/cadence sensor does not even come up in the list of available devices in the pair screen. That is what I need help with.


(Paul Allen) #8

Need to ask a couple question just to verify things.

  1. Have you tried other USB ports on your computer (the one on the back would be the best option)?
  2. Have you tried a new battery?
  3. Di you wake the sensor up before searching for it on the Zwift pairing screen?
  4. How long is the USB cable?
  5. Model number so I can look up some specs of it?

I would suggest also trying to work out the bugs/issues you are having with the power meter since that will give you a better Zwift experience. Does make you wonder if you are having issues with your power meter and the RideSense that there might be an issue with the USB ANT+ dongle or USB cable.