Zwift/Zwift Power Not Including Stryd Data

In the past week, perhaps following the most recent Zwift update (?), Zwift/Zwift Power has stopped recording and/or showing Stryd power numbers. This may be an unintended consequence of the update. A knock-on effect is that resulting .fit or .tcx files, that normally can be uploaded to the Stryd PowerCentre, are now being tagged as ‘not supported file format’. These file formats are normally supported by Stryd, however, this error message is likely the result of the files lacking power data.

It’s requested Zwift/Zwift Power return to including Stryd power numbers.

Hi, had the same problem und fixed it, when you first uses ride. Then you should use Stryd as power control. Then switch to running and you will have a Stryd compatible file. Hope this will help you.

Hi Erwin: Thanks for the reply. I tried your suggestion today and it did not work for me, can you confirm if it still works for you? Zwift was recording Stryd power without using a trick like this before so I’m hoping it’s something that can be fixed. Regards; Chris

Hi Chris, it worked for me, but I reseted the Stryd before I think!

Having the same issues this week. No power with stryd. Will try work around but hope Zwift is going to fix

I have the same problem, only solution so far is to dual record with my garmin …
I can tell it is since i updated on the 17th of june

I found somewhere they suggested connecting Zwift via RunCline (Runcline connects to Stryd and a HR monitor and retransmit to Zwift). However, Zwift couldn’t find Runcline to connect to. Anyone having the same problem?

But best would be if Zwift could go back to reporting power from Stryd.

I don’t hold out much hope for a (Z)swift fix. Zwift Chief Product Officer YC Cheng in a recent interview stated that Zwift’s primary focus is cycling (let’s face it running is stuck in forever Beta land), and Stryd appears only interested in supporting outside running after dropping the Stryd Live foot pod. At most both corporations appear to be simply tolerating treadmill running and neither is engaged in actively promoting and building a TM user base.

Had this same issue a few weeks ago. Today I downloaded my run from Zwift and it’s not in .fit format so that run also cannot be uploaded to Stryd. Are others also still having issues?

Still the same. It seems Zwift is no longer registering power from the Stryd foot pod, so it makes no difference what program you import from into StrydPower it will show as incompatible file format. For me StrydPower has become somewhat pointless as it’s only registering my outside runs.

Looks like this is correct. Zwift no longer gets power from stryd automatically,from either Bluetooth or ANT+
Now this is what Stryd has put on there forums to get a work around

This option only works if you pair Stryd to Zwift via ANT+. (This trick will not work if you connect Stryd to Zwift via BLE) Before you start your run on Zwift, you must pair Stryd in a special manner to ensure that Zwift records power data in running. Please tap on the RIDE option on the pairing screen and pair Stryd as a power meter. After Stryd is paired as a power meter, switch back to the RUN option and ensure that Stryd is also paired as a foot pod. Then, you can start your activity. Zwift will record your run as a FIT file. You can export that file, and import it manually into PowerCenter. Once you save the activity in the Zwift app, it gets uploaded to the Zwift servers. To get the FIT file, you need to login to your Zwift account on a browser on your computer. From there you can download the FIT file, which you can import into PowerCenter (also on the computer).

Eriwin was right but you’ll need ant+