Zwift world not loading on Apple TV 4K, app crashing


I have recently updated to version 1.43.0 of zwift on my 2022 Apple TV 4k.

It connects to all my Bluetooth devices, but once the Zwift world (route) has been selected, as the route goes through the normal loading process, the app crashes and reverts to the Apple TV home screen. This happens when just riding, selecting a workout or pace partner!

I’ve uninstalled and reinstalled the zwift app, but this has not worked.

I would welcome any ideas of how to fix this issue.

Many thanks


Make sure tvOS is up to date

Compare stability pairing via Companion vs not

Do not pair Play controllers if you have them and see if that changes anything

If all else fails, do a factory reset of the Apple TV device

1 Like

I’ve had this problem recently. First time was last week when I could load Watopia but not Makuri Islands.

On Monday and Tuesday this week I could Zwift normally (I’d turned my Apple TV off and done a long hold of “home + TV” to reset it, which might have helped), but on Wednesday I couldn’t load any world.

Things were OK again today after updating and the Apple TV being unplugged for a day, but I don’t have a specific way to fix it.

1 Like

I constantly have this same issue. Restarting the Apple TV seems to fix it. At least for a couple days until Zwift starts crashing again so I restart ATV again.

Have you already tried a factory reset?

Hi all.

The only thing that appears to have worked is the factory reset of the Apple TV. Have only had 2 or 3 rides in zwift since, but appears to have done the job.

Thanks for your suggestions

1 Like