Makuri Islands crashes on Apple TV (June 2023)

Is anyone else finding Apple TV crashes while trying to load Makuri Islands at the moment?

I don’t see a current thread (although there have been several Makuri Islands crash threads in the past), but every time I tried to ride with a RoboPacer in Makuri Islands, the app crashed after around 10 seconds.

I was able to ride on Watopia for 20 minutes without any problem.

Which model of ATV?

No issue with the latest (2022) ATV4k for me, running the latest version of Zwift.

Option of last resort (or first, if you want to be sure) - reset the ATV and start from scratch. On boot, reinstall latest OS updates, then Zwift. If that doesn’t fix it, you know something’s really messed up.

EDIT - I’d add: always, always, ALWAYS force close the app after use! In theory you shouldn’t have to but with Zwift on ATV, “the difference between reality and theory is, in theory there’s no difference.”

Brand new, 4K bought this year. Latest Zwift.

1 Like

Yeah, I’m voting “nuke and pave.” About every year, year and a half, my ATV goes absolutely bonkers and won’t play nice with Zwift. I suspect there’s just some bit of legacy code left from a previous Zwift install and it’s gumming up the works.

:sob: that means typing in my password again :sob:

You can dictate it with the Siri remote. :wink:

If I knew how :joy:


1 Like

I’d test and verify for you on my setup, but I’m currently locked in my room w/Covid. The warden aka wife would go bonkers if I stepped out to mess w/Zwift.

If you have an iPhone, you can cut/paste the password. That’s what I do. Otherwise, you can try the Siri Remote. Although I’ve never tried it, seems simple enough: Siri Dictation

p.s. I know @Otto_Destruct likes to advocate the “Nuke it from orbit . It’s the only way to be sure.” approach, but I’ve never had to go that route. No reinstall of Apple tvOS. No wipe and reinstall of Zwift. :person_shrugging:

1 Like

Hi folks, in the next game release, we’re releasing some fixes for game crashes that could occur when loading into world or routes which may be related to some of the issues discussed here. Stay tuned.


Makuri Islands crashed on my three times today on Apple TV. Deleted the app and reinstalled and had the same issue. Switched over to Watopia and rode the whole ride. IN Makuri, I’d lose sound about every 10 seconds, cyclist would freeze and then it would come back further down the road. Seemed like any interaction with the Apple TV would crash it. Even plugged in my remote charger and it crashed. Makuri seems to have quite a few bugs in it still.

Video screenshots enabled in settings? Try with that off.