Can’t get into TDZ stage 8

Tried to join stage 8 - zwift tells me it’s loading Makuri Islands then crashes. Tried 5 times - B and C ride, from Home Screen and free ride. Nothing

Anyone else seeing this?

It loaded up great for me. Double check that you have the latest version installed… restart the computer… hopefully it’s as easy as that

1 Like

Its really good BTW, I loved it. have fun racing it! lots of places to use your zwiftcraft and take advantage of the course elements. Cant wait to race on it myself!

Apple iPad. Version 1.33.0 (1.33.2 isn’t in the App store yet).

From the home screen if I join Stage 8 directly it says “Loading Makuri Islands” and then it puts me in Makuri Islands and then immediately says “Changing Worlds” and a second later I’m in Scotland (at least it’s not crashing for me).

That’s not normal behaviour is it? Usually you go directly to the world if you Start Ride for an event on the home screen? So it’s odd that Zwift is loading Makuri first before transferring me to Scotland.

From a free ride in Watopia it works as expected to join an event going directly to the pens in Scotland without the side trip to Makuri Islands.

I also tried from free ride and same happened. I then tried a computer restart and an early join on the later event and it spawned me Chasing the Sun instead

I have to go to work but I did just try joining the 7am from my phone and that works so it’s something to do with the computer rather than my account. Have emailed myself this morning’s logs to see if I can find anything

Edit - all logs showing this just before the crash


As you know I’ve created you a private event to try again when you get home.

If that doesn’t work please try and reinstall Zwift on your PC just in case it’s the installation that’s the issue.

1 Like