Zwift Workout Plan - FreeRide time

Guys / Gals 


I am currently going through a 4wk ftp booster coming towards the end, I have done a 6 & 10 minute (Hold as much power as you can)


Here Is the issue, It moves in freeride mode and my tacx vortex is adjust on gradient, Is this a bug or am i doing something wrong, If im trying to hold power for 10 minutes and its yoyo’ing the figures are all skewed,


Any feedback appreciated,



I had the same problem with this specific workout plan. The free ride is not simulating a flat road as in other workout plans. I have not expected this behaviour and therefore my wattage was all over the place. There is a parameter in the workout code to define if a flat road is simulated <FlatRoad=“1”>. It seems that the creator of this workout plan has not defined this parameter.

I think the final ftp test in this workout plan has the same problem (not 100% sure though). So it might be better to use one of the standalone ftp tests at the end of your workout plan.

Thanks Ivo, I’ve raised a case with Zwift, see what they come back with, 

The free ride is in resistance mode:  it’s a holiday within the training.  It’s just like normal riding in Zwift except that you are in a workout (the vertical bars appear below your name); you get no drafting benefit; and if you are on a Tacx Neo there is no “ road feel”.  You should note that when you choose a free rode segment of the workout plan, you don’t see the checkbox for erg mode. 

It’s sort of weird but you get “class credit” for just riding. 

You can copy Zwift workouts and edit them, after which they are saved to your local Zwift folder. When I open the files with the 6 and 10 minute best efforts, both have the FlatRoad tag set:

6 minutes: <FreeRide Duration=“360” FlatRoad=“1”>

10 minutes: <FreeRide Duration=“600” FlatRoad=“1”>

This is the same tag used in the regular (long) FTP test: 
<FreeRide Duration=“1200” FlatRoad=“1”>


So this is definitely a bug, you shouldn’t feel the road gradient in the free ride sections.