Free Ride Step in workout completly broken - No resistance and incline change after v1.25.0

When doing a workout, one can include free ride blocks. Before 1.25, they also gave resistance and grandient changes to kickr and climb. But after 1.25, there’s no change in resistance and grandient anymore while being in a free ride step of a workout.

But once you finish the free ride step, you get a big bump up incline change on the kickr climb, but it doesn’t even depend on the actual gradient of the map.

Noticed this while doing a workout which included free ride steps followed by ERG mode blocks and vice versa. The ERG mode blocks did work as intended.

Something is messed up with the workout feature in v1.25. See my other thread, maybe they correlate with each other: FPS issues after update to v.1.25.0 while doing workout

Today, I did another workout which included Free Ride steps. Again, no gradient based changes in resistance for my Kickr. This is so annoying, Free Ride step in workout is completly broken since the v1.25.0 update.

Just on the off chance… you don’t have trainer difficulty set to zero, do you?

Good Point. But I haven’t, it’s still on 50% like it was before the Update. Just checked in the prefs.xml, it’s still set to 0.5.


Any chance this is beeing looked at? @Steven_D I’d really appreciate a check on this as it’s an essential part of workouts in general.

And it worked perfectly fine in all game versions prior 1.25.

Hi Mike.

What workout was that. there are very few workouts that will simulate the terrain during free ride, most will be flat road where you can adjust the resistance in the companion app or the ± keys on the keyboard.

1 Like

Hi @Mike_Medwed

Hard to say, Mike because like Gerrie said and to my knowledge, most ERG mode workouts aren’t supposed to simulate resistance changes when the gradient increases/decreases. It’s usually just a SIM mode thing where that happens.

If there are specific workouts where you notice you have been able to do this previously in free ride blocks, I can take your issue to the team and try to get some feedback for you. Thanks!

From the original post, I think Mike designed a custom workout that simply included Free Ride segments. Meaning, I think, that this means the ERG mode would effectively turn off (hence ‘free’) and wherever you’re riding, that’s where the “free” ride portion occurs; so you’d be subject to whatever the course terrain hands you?

No. Free ride by default does not simulate the terrain as I said before.

There is spesial cases to do that but it needs to be done in the zwo file.

Interesting. So what exactly does adding a Free Ride segment to a custom workout give you? Basically emulated flat terrain only, no matter if you chose the AdZ as your training route?

Correct. Basically it’s just the removal of a power target for your trainer in that segment. No gradient changes on your trainer, but you can do whatever power you like.

Built a custom WO this evening with freeride and freeride goes into SIM mode (feel the terrain). Checking the zwo file, flatroad=0 which is SIM mode whereas flatroad=1 is flat. I have no idea if this has changed as OP indicates however as I have never used a freeride. Doesn’t appear that OP has confirmed whether its a custom or Zwift WO either.

@Dean It was a custom workout which I built inside Zwift, so yes. I’ll check the .zwo file if flatroad=1 is enabled. Can you please send me the text line of that step so that I can see how the syntax should be?

Here’s my test zwo:

So change Flatroad value to “1”.

Good luck @Mike_Medwed

@Dean Just to make sure, Flatroad=0 is SIM mode, so I get resistance and grandient change based on actual terrain, and Flatroad=1 is basically what I’m currently experiencing, no change in resistance?

That could very well be that this got changed somehow during the last updates.

1 Like

see this post

@Gerrie_Delport_ODZ @Dean Thank you both so much!

I did some digging into my .zwo files. I created two workouts using the Zwift Workout Builder. These two have Flatroad=“0”.

I then just copied one of the workouts two times inside Zwift workout window and altered them, e.g. changed length and included a few repetitions. These copied workouts all had this parameter set to FlatRoad=“1”. These workouts where the ones I rode and experienced the changed behaviour.

This is interesting. Maybe it’s not because of the update, it’s because something got changed during the copy process. Or if it’s related to the update, it changed the default parameter to “1”, because I copied them afterwards if I can recall this correctly.

Anyway, I’m quite confident we found the solution to this.


So a bit confused from what I’ve read so far. If you build a custom workout, and include a Free Ride segment, then default setting is indeed that terrain will be felt and not flat?


If you build a workout with free ride, it is set to resistance mode, it won’t simulate the gradient of the road.

If you want to simulate the grade in a workout you need to edit the file in a text editor.

This is kinda contrary at least somehow. I can assure you that I’ve created the workout from scratch inside the workout builder and the .zwo included FlatRoad=“0”. I didn’t manually edit the file afterwards.

After copying one of the two workouts, these had FlatRoad=“1” set. I also didn’t edit them after creation.

Otherwise, this thread would be a bit nonsense. :slight_smile: