Zwift RunPod firmware

If you haven’t updated your RunPod firmware (via MilestonePod App), please check it out by downloading it after you pair on Zwift in-game. Let us know if you’ve seen improvements in your running experience, or if you are finding any issues.

UPDATE: We have a support article going over the process HERE.

Firmware is updated via the Milestone App, correct? Are you saying this is done WHILE the pod is paired with a Zwift session? I did not think that was possible since a BTLE device can only have one active pairing.

Yeah need more clarification on this. Just checked and neither the Milestone app nor Zwift say anything about a new firmware. Is firmware checking going to be part of Zwift?

When you pair the RunPod to Zwift, Zwift will recognize if the firmware is outdated. A prompt will come up on the screen asking you to update the RunPod’s firmware. It takes about 3 minutes or so. It should be possible to update through the MilestonePod app, but it’s easier to do this in Zwift instead.

1 Like

Same here. I ran in Zwift today and it didn’t say anything about a firmware update. No firmware update from the Milestone app either.

Mine updated through the milestone app, it threw an error near the end of the update but hasn’t asked to update again so assume it actually completed, is there a way to check firmware / force an update? I’m struggling with hitting the higher speeds in Zwift still.

To check the current firmware version or battery life of your footpod, tap the footpod icon in the Milestone app and a popup will display this information. The latest firmware is version 4.0.52 (For the Zwift RunPod only).

1 Like

I had to install the Milestonepod app to check my firmware version and I only have 3.0.76. What’s new in 4.0.52 and is there any way to force an update?

Hey there - are you using a MilestonePod or the Zwift RunPod?

I’m using the MilestonePod.

Thanks for that info - the MilestonePod is not currently able to update firmware in-game on Zwift. You’ll still need to check that via MilestonePod App, which it looks like you’ve done. If it isn’t prompting a firmware, then you’re all up to date :slight_smile: The 4.0.52 firmware is for the Zwift RunPod.

Thanks, but this seems to suggest that the Zwift RunPod isn’t just a rebadged MilestonePod. Time to buy one then.

Aaron_Smith,

You are correct that the RunPod is intended to have a single active connection at one time.

Previously, the only means of updating Zwift RunPod firmware was through the MilestonePod app in an active connection (outside of Zwift). However, we are happy to report Zwift RunPod firmware updates are now possible from within the Zwift App (outside of the MilestonePod App).

The two apps handle firmware updates differently. When a Zwift RunPod is connected to the Zwift app, the firmware version is checked to see if a newer firmware version is available. If a new firmware is available (and you are not in the middle of a run) Zwift will prompt you to update the RunPod (or you may choose to be reminded later – in about a week).

However, as OP mentioned, you may have already updated separately through the MilestonePod App (outside of the Zwift App), then your RunPod is probably already up to date and you will not be prompted for an update through the Zwift App until a newer firmware version is available.

Either way, we would be interested to know if you are having a better experience with your updated Zwift RunPod.

And if you did update the Zwift RunPod firmware through the Zwift App. How was the update process?

1 Like

I have the latest firmware and have a lot of drop-outs. Using iPhone XS with Zwift running during irl outdoor runs. My avatar stops and starts running.

Bluetooth is designed for indoor use and is designed to reflect off walls. For outdoor Bluetooth usage, try bringing the phone closer to the pod, such as strapping the phone to your calves.

1 Like