Zwift play ride on return

During game play some recieved ride ons say press z for me to give a ride on return. Some questions:

  1. Not all ride ons tell me to return a ride on. It’s this a bug or is there something unique about certain ride ons?

  2. Some times when returning a ride on I get haptic feedback while other times I don’t. Do the times I get haptic feedback mean a ride on was delivered?

  3. Because the feedback is inconsistent perhaps a visual cue when successful would be a better acknowledgement.

  4. Even when returning a ride on with haptic feedback I believe the acknowledgement was faulty. I checked a rider profile through the companion app after returning the ride on through the controller. The profile showed I hadn’t sent a ride on as their ride on box was still shaded blue even though I received the haptic feedback.

Very happy with the controllers so far and I’m looking forward to future updates.


you are able give a return ride on if that person is currently around you in the ride, you wont be able to return a ride on from say a friend who isn’t on zwift and has just done it via the companion app

1 Like

I have the same issue to Item 4. During a ride when you respond back to a Ride On using the Zwift Play I don’t see the thumb drop and when I check the riders profile his Ride On box is still blue. Is this just a delay in the system?

I concur with Bernard on all of the above.

The sole reason I purchased the play controllers was the ride-on reciprocation.

Everything else works terrific but that feature is so inconsistent for the reasons he stated.

I came in here to start my own thread, but it’s already here. Please do a firmware upgrade to resolve this?

The community aspect of zwift is of major importance, and this ride-on feature is the largest proponent.

Fix this please. Thank you.

I get it, if the person isn’t in the ride you can’t give them a return.


You still don’t get it. I am not asking about returning ride ons to a person not on a ride with you. A person/friend right next to you during a ride may or may not get a ride on returned to them. It is extremely inconsistent with no feedback mechanism. This is definitely a bug although there is no way I can point to the Play controller or the game itself that is the root cause of the issue.



Sorry didn’t see you were responding to another person.


Bernard, I am having the EXACT same concern and issues as you with riders next to me. Yes, I get it.

We both want a better experience from the button.

I have pressed it within seconds, and got NO haptic feedback, and the member still hasn’t got my Ride On. Like you I check their profile (quickly while spinning)!

Even worse is it sends a group ‘Ride On’ which initiates more folks sending me one in return. Which I can’t do quickly.

This is an important feature which needs updating.

I hope someone in the tech arena reads this to look into it.

Thank you.

As a start, are you sure you’re pressing the Z button quickly enough? I find that the ‘return Ride On’ window is exceptionally short. Second, if you are getting the Ride On bomb happening, I think you might be holding the Z button too long. To return a Ride On is just a press and release action. The Ride On bomb (group Ride On) is a press and hold action.

Hi Nigel,

There is definitely no question I’m hitting the Z. While I’m not dismissing your thought it could be a timing issue we’d only be speculating.

My thought on coming onto the forum is this was being monitored by Zwift developers and this would be treated like a client reporting a trouble ticket.

If there is developer or tech analyst that is monitoring this and would like to use my log files to see when a ride on is sent and my Android devices response I’d certainly be willing to assist.

However me or another user speculating what the issue may be without any tools or subject matter expertise is just a time toilet to be honest.



I have tried a quick short press within the announcement window, and then tried to hold it longer when ineffective (releasing a torrent of 'Ride-On’s).

There HAVE been times it has worked, but more often it does not.

If the small announcement window (“@****** just gave you a Ride On: 'Hit the Z button to return a Ride On”) comes up, I jump on it accordingly.

Then I unwillingly scroll through the MOVING maze of riders in my Companion App to find said rider, and click their profile, only to see the ‘Ride On’ button is still available (not greyed out, allowing it has been sent.)

TECH SUPPORT: Please review?

I offer a couple of observations: -

  • You have to hit the Z button whilst the “drop-down” is visible.
  • Receiving a couple of Ride Ons in quick succession usually means I am only successful in returning one of the two. There appears to be no pattern as to whether the first or the second is successful. I am guessing (as a non-techie) that the signal channel gets congested. In these instances I use the Companion App to check which of my responses has been successful and to action my second response.

I’m not sure how quick you are with scrolling through the ‘Riders Near Me’ list, but I have noted that when using the Ride On Bomb that it can take a bit (3 to 5 seconds, maybe?) before I actually see the thumb drop down over the riders near me. So, perhaps you are just too quick? I’m not saying there isn’t a bug of some sort, just that I have noted that it can take a while after pressing the button before the Ride Ons are actually delivered.