Zwift now super strict on calculating workout stars [1.25.0] [SOLVED]

@Rob_Snow_NBTX I believe the Zwift setting you refer to is “display power” which can either be “instant” or “3 second average”. I have mine set to 3 seconds whereas “power smoothing” is the Wahoo feature.

With regards to the comment about ERG in my reproduction - yes it was definitely on - it would be very obvious to me if it was not. I.e I hold the same cadence, don’t change gear, and the trainer brings the resistance up from 50% to 150% of FTP as enter the interval, holds it there to cope with any variations in cadence/effort and drops the resistance back down at the start of the next interval. Going from 50% to 150% with ERG off would definitely need a gear change…

With how “smooth” it looks, bear in mind that the entire ride is only 3 mins, enough to reproduce the problem. So you are effectively “zoomed in” when looking at the ride report.

1 Like

Perhaps Zwift now assumes you have Wahoo’s power smoothing feature enabled.

@shooj - Do your testers who can’t reproduce the issue have Wahoo trainers with power smoothing enabled? If so, ask them to turn power smoothing off.

I have a kickr with power smoothing enabled and it is still a problem.

I always have erg mode enable and my power never ever has once looked that smooth! across many different trainers.

Your trainer must be sending the target power or something to zwift to get it like that. Either that or you have the world’s smoothest pedalling stroke ever.

That was my power from earlier and that has power match enable on my trainer which smooths it slightly from the pedals.


I’ve got to agree with @Chris_Holton . Your power trace looks like it’s been produced by an ANT+ bot, not a person. I’m not seriously suggesting that you really use a bot, but there’s no way that that’s showing your actual generated power without some massive smoothing.

1 Like

That is Wahoo’s build in Power smoothing. Looks exactly like my workouts, have Kickr18 with power smoothing enabled as well.


As i said, its wahoo’s ERG mode power smoothing. If i turn it off my power flucuates just like @Chris_Holton’s. I guess i kind of figured most trainers had that option too?

I guess this does go back to the original question of what it was about their screenshot that made them think they had turned erg mode off? It all looks pretty normal to me.

To be clear, with power smoothing on, your power is still fluctuating just the same as if you have it turned off, it’s just that the trainer is reporting to Zwift differently.

Let’s not mince words. Power smoothing is a lie.

1 Like

@Wannie @Jim_Mattson luckily we’re not reporting power smoothing issues, we are reporting that Zwift now calculates workout stars different since the last update no matter if smoothing is enabled or not. This affects all Zwifters, just try it out for yourself.

So can we return to the topic, please?

I don’t think they do. Certainly Elite trainers don’t, and people sometimes complain about ERG mode power on Elite trainers since it reports the power extremely accurately, and a very jagged trace makes some people think that it’s not working properly.

@Mike_Medwed what trainer do you have?

I’m using a Wahoo Kickr18.

I’m also on a Kickr 18 and I’ve tried it with Wahoo smoothing on and off, no dice. I’m still failing short intervals that I’m not actually failing. It looks to me like there is a delay in the ERG ramping up the resistance compared to pre-update.

I’m on a ~2014 MBP quad core, 16GB w/Nvidia 650m for completeness.

Oh, I have definitely been denied stars. Apologies for veering off-topic. I’m as eager for a fix as you are.

Everything’s fine :beers:

Just want to make sure the thread doesn’t drift off so that ZHQ can concentrate on a fix. :+1:

Assuming that the principal complaint is the XP loss…

I have a workaround, though it isn’t great. Use a third-party app to drive the workout and control the trainer. On Zwift, just do a free ride on Tempus Fugit to minimize the XP loss. Remember to unpair the controllable trainer on Zwift.

I do this anyway for workouts with ramp blocks, since Zwift penalizes ramp blocks for XP gain. (The logic behind that decision escapes me.)

@Jim_Mattson That’s an option I’ve considered and I do it for some workouts Xert, TD, GC, etc. When I can, I just assume do it all in Zwift as it’s less jacking around with what is connected where. Unified, if you will.

I’m having the same issue on a Kickr V5.

Thanks for flagging it and providing all the details.

Hoping for a quick fix!

1 Like

FWIW my no-star efforts were on a Tacx Neo 2T. It’s been fine since for workouts such as The Gorby and Debbie’s Killer Minutes, where the interval power isn’t massive.

For pure sprint workouts like Violator (which I’ve transcribed to .zwo from Sufferfest), I’d do those in sim mode, but there are a few in-betweeny workouts like The Wringer where erg really helps to moderate the effort to get you through the intervals.