Zwift now super strict on calculating workout stars [1.25.0] [SOLVED]

I do a lot of ERG workouts in Zwift and there hasn’t been an issue so far. Due to ERG Mode, I hit my workout goals pretty good.

Today I had to ride intervalls of 315W, which I matched. Watts showed as 315, and reported watts where between 316W or 314W.

With v1.24.2, it hasn’t been an issue and I always received full golden stars in every step. However, with v1.25.0, Zwift now seems to be super strict how the calculation of the workout goals is done as I only received half golden stars for a few steps.

It seems that there has been a change how the stars will be calculated. It’s not really motivating, and I imagine myself that the Zwift squirrel appears and shouts at me: “You little lazy blob, you can do better!” although I did pretty well. Oh, and only half of the XP are credited as well.

ERG mode is ERG mode and there’s not really a lot to do. You always hit your goals unless you stop pedaling or the trainer has an issue.


I thought the same, @Mike_Medwed - I did The Wringer on Saturday night (perhaps not a workout particularly well-suited to erg mode, but…) and I kept the pedals turning throughout all the intervals, but only got 1/2 a star on four of them, and no stars on the other eight. I’m not especially fussed, but I thought it was a big harsh.

EDIT Just checked and last time I tried The Wringer, I was given a full star for all the intervals I did (although I was feeling like a bag of spanners and bailed after four reps)

It looks like something is broken in the latest update.

For The Wringer my target is 490w, checking afterwards I averaged 488 and then 493w for the first two and it didn’t give me a star either time. I reduced the intensity in case I wasn’t hitting the target which made the rest target 110w, I averaged 115 as I didn’t drop it straight away, it gave me a full star but only 4 points XP for a 2:40 interval. I gave up at that point and hopped on a pace partner where it decicded to ignore my correctly displayed cadence and show me not pedalling.

At that point I gave up on Zwift as a waste of time.


Yep, same issue here. Seems incredibly strict on some intervals, and doesn’t play nicely with ERG - even those at lower watts where I might be +5 watts for the duration.

Same experience here, 30 second intervals failed in ERG mode going from 155 watts to 280 watts, takes about 3 or 4 seconds for the trainer to get up to that resistance and failing the interval completely or getting half a star.

@shooj @Shayne-Gaffney have the tolerances been changed? I’m sure you wouldn’t design a workout that automatically fails people, this needs some looking into please.

Please also see the issues with frame rates dropping to ridiculous levels now during workouts:

1 Like

Thanks for cross referencing :+1:

Thanks for flagging this up. I’m asking the team about it.


I’ve had this issue as well.

It appears to be for short duration workout intervals with large increases in power.

I’ve done the same workout many times before and only now with version 1.25.0 am I being given 0 stars for the interval.

Nothing else has changed about my set-up. I am keeping a steady cadence going into the the interval and coming out of it so it is down to my Tacx Neo to use its ERG mode to bring the resistance up to the appropriate level to attain the power in the interval as normal, which it does successfully.

See the three 30s@465w interval s in the screenshot below including the power graph at the bottom showing the ERG mode keeping a consistent 465w (but no stars awarded).


This issue appears to be 100% reproducible in a couple of mins with the steps below.

Environment: Zwift version 1.25.1 (latest) on Windows 10 with Tacx Neo trainer controlled by ANT+.

Choose “Attack!” workout from Build me Up plan, ERG mode on.
Skip intervals from Companion app till the first 2min @ 85rpm, 50% FTP interval
Increase cadence to 110 rpm shortly before the next interval.
Maintain cadence of 110 rpm through the next 30sec @ 110rpm, 150% FTP interval as ERG mode of trainer brings power up and maintains it at 150% FTP.

Expected behaviour - full star given for 30sec @ 110rpm, 150% FTP interval
Actual behaviour - no star given for 30sec @ 110rpm, 150% FTP interval.

@shooj have you had a response from your team?
Could you get this reproduced and fixed?

Please let us know if you need anything for else, for example can share the .fit file.

Screenshot during 30sec @ 110rpm, 150% FTP interval:

After 30sec @ 110rpm, 150% FTP interval showing no star awarded:

Ride report:

1 Like

Yes, a couple of testers were not able to repro with their setups.
I’ve passed on your post for further testing, thank you for your diligence.

Please test on 8sec @ MAX sections of “Endurance With Max Sprints” workout.

Prior to v1.25.0 I was able to get all stars with 723 watts MAX on the aforementioned workout. However, with v1.25.0, I was not able to get any of the 8sec @ MAX stars with 738 watts MAX. It kept asking for more power.

Questions for you:

  • In this shot, it look as though you had ERG mode disabled at the moment? Do you recall if you put it into SIM?
  • Do you have power smoothing disabled / are you using power matching?

We had a couple people follow your steps, and both were able to get the full star without issue. We’re wondering if there are other steps you’re doing that we’re overlooking on our end?

Came here looking for why I “no-starred” my short intervals this week after the update and found this. It was an ah-ha moment. As luck would have it, Thursdays workout from this week was exactly the same as Thursday of last week (before update for me).

It has some 175% 15s blocks early in the warmup and then some 15s blocks on the front and back of SST work. I failed all of those 15s blocks, but all the longer blocks I “starred”. 1m blocks were hit and miss, depending on the size of the change. I should add that there was no change in “me” between the workouts, same cadence, same effort, felt good, etc. Last week was all stars, this week was no-stars on any 15s and no/half stars on other short intervals.

When I look at the workouts in, they are mirror images with 3 BPM difference…but you could lay on on the other and not tell the difference.

This is with 1.25 and a Wahoo Kickr with pedals for power/cadence.

So setup something with 15s 150% intervals with a break between and see if you don’t fail/no-star them.

1 Like

I’ve noticed this too, if you are off target for even a tiny amount of time it doesn’t award the star.

Definitely different to how it used to be.

I went and looked closer at and check this out between last week and this week. You can see the delay in the interval starting and that’s why I failed/no-starred. It still runs 15s, just not at the right time.

Last week, star:
Screen Shot 2022-05-20 at 10.28.09 AM

This week, no star:
Screen Shot 2022-05-20 at 10.28.02 AM

Hi @shooj
Thanks very much for the reply.

I did not disable ERG. Could you tell me just for my own interest what in the screenshot indicates that it might have been disabled? Happy to repeat the test if that helps.

I believe power smoothing is a Wahoo trainer specific feature so not something I could disable on the Tacx Neo trainer I am using. Please feel to correct me if that’s wrong.

I am not using power matching i.e. am not using a separate power source - both the power source and the controllable device is the Tacx Neo.

@shooj Yes, I’m willing to try anything out to fix this. As you can see, I’m completing the interval, but when you in the “go”, you like to see that star as a positive reinforcement that you’re getting it done.

Your power is not even and smooth, the line is jagged which looks like no ERG mode. Are you having to change gears to increase power, or does your trainer do it automatically?

Notice how smooth my power looks, this is what is expected in ERG mode.


That’s power smoothing, that’s not no ERG. My understanding is that this can come from two places: 1) Wahoo trainers can pre-smooth the power that they send to Zwift. 2) Zwift can smooth the power too in one of the settings. I have turned that off for a couple of years now because I want to see the reality, helps me see when I fatigue when I start “zooming”.

1 Like

I’ve also got a Wahoo and my training rides are the same as Mike’s with ERG on (smooth intervals on workout graphs). Here’s a snip of one where I turned off ERG for a bit a couple of times (and I have 3-sec soothing on) which is reflective of the what my normal graphs look like. If I had smoothing off, my graph looks like an out of control ECG graph as I am far from smooth.