Zwift not displaying who i rode with once uploaded to Strava

Not sure if its since the last update but the last two rides i have done on zwift including tonights Tour of watopia stage does not have any of the people i did the stage with listed on strava, I tried deleting the strava entry and manualy uploading the fit file from zwift but it still looks like i did the ride on my own which is rather frustrating! Has anyone else had this problem or is it just me?

I’ve had it happen when I had incorrectly set my PC’s clock but not really heard of anyone else that problem (I went searching and found nothing when it happened to me).

1 Like

I haven’t done many group rides, but I think it did happen with one of them and I thought it was due to the size of the group. I got the impression that if there were too many people strava just didn’t put anyone in the list.

1 Like

I checked a bunch of other rider’s activities in Strava. Its fairly hit and miss. Some riders show 100-200 others that they rode with, but others show nothing. Glitch in the Strava machine it seems.

1 Like

Thanks for all the replys guys! It looks like it may have been a fluke as the second stage has shown the other riders this time! I had not heard of the time issue and so prehaps i forgot to change the time on the pc after the clock went back, it was also a 5000+ event so could very well be a issue with so many riders, I had seen quite a few others from the first stage with the same problem! Fingers crossed it might be solved!

1 Like

they just changed/updated privacy settings on strava recently so might be to do with that.
think they’ve given people the option to opt out etc.

1 Like