Zwift Not Applying ERG Mode to Tacx Vortex Smart v3.1.13


(Mark Goldstein) #1

Hi,

I’m using the latest version of Zwift with a Tacx Vortex Smart running the latest firmware (3.1.13).

In Workout mode, Zwift doesn’t change the resistance as the target wattage change - the only way to keep on track is to either alter the cadence and/or change gear.

The Erg Mode box is ticked for the workout before starting.

It also didn’t work on the previous Vortex firmware version either (3.1.7).

Zwift does change the resistance for hills/descents when riding around on Richmond/Watopia.

I’ve also tested the Vortex with both Tacx TTS 4 and the Tacx Workout app, and they both successfully adjust the trainer resistance as the wattage changes, whilst I’m staying in the same gear and pedalling at the same cadence.

Is there a way to troubleshoot if this issue is specific to Zwift?

Thanks,

Mark


(Mark Goldstein) #2

Ooops - the title should read “Zwift Not Applying ERG Mode to Tacx Vortex Smart” !!!


(Alistair Aitken) #3

It was working fine for me in workout mode last night using a Tacx Bushido Smart and 3.1.13.

The only issue I have is that if you pause at any time, the turbo stops the ERG mode. This then resumes when getting to the next block of the workout. The system is supposed to resume ERG if you maintain the correct wattage manually after a pause, but this no longer seems to be working. In my workout I paused for a few seconds shortly after starting (spin to power up bushido then stop to sort out fan and get going) and this was enough to have to do the 10 min warmup without ERG mode.

ERG mode resumed for the 2x25min at 200W with 10min rest, worked fine.

I think what is needed is a resume ERG mode button, or a more reliable resume ERG mode automatically. Also, zwift should not cancel ERG mode after a pause, this doesn’t make sense. It should only cancel if the rider fails to achieve the wattage (i.e. is forced to stop pedalling in a high watts segment), but should resume quickly and reliably.


(Mark Goldstein) #4

I’ve now successfully used my Tacx Vortex Smart with Trainerroad in ERG mode, so it doesn’t seem to be an issue with the trainer.


(Martin Bjorgvik Sz) #5

is this working now Mark? I´ve seen the firmware update but has not updated to it yet


(Mark Goldstein) #6

Yes, I’m running the latest update and the workout mode is fine with Zwift.


(Jonathan Neve) #7

Mark, 

 

Is the latest update you are referring to a Zwift update or Vortex firmware? I am having the same problem and running Vortex 3.1.13 which is the latest version as I am aware of… Is this incorrect? 


(Ruth Powell) #8

Hi,

I’m having the same problem. I’m running Zwift on a Mac Book Pro (not sure that has anything to do with it). 

I’ve just started the beginner 6 week FTP programme. The first couple of times it worked great in ERG mode. I then ‘experimented’ and unchecked ERG. Now it won’t go back into ERG mode (despite checking the box) and I am left having to adjust my gears.

I now also find it impossible to match the required wattage with a reasonable cadence. My wattage ouptut is much higher than required by that particular  block of the training. I can’t reduce resistance using my gears without making it impossible to maintain a comfortable cadence of 90-100 rpm. 

I am assuming this part of the software is rather ‘buggy’. My next step is to remove and reinstall Zwift and see if that has any effect and then to not tough the ERG setting. My Taxc Vortex is using the latest firmware, and I believe I have the latest version of the Zwift software.


(Paul Trenoweth) #9

Ive always had issues with ERG mode and on the workouts. I have a Tacx Genius Smart (T2080) and it never auto adjusts resistance down when I am over the wattage set point. i.e. If my block is 250w I ALWAYS get the reduce power warning come up as the trainer doesn’t adjust to less resistance. It seems to increase the resistance ok and on lower wattage it seems to be better.  It just doesn’t seem to adjust the resistanc to accommodate greater inputs over the ‘set point’ pretty annoying and last winter I went through both Tacx and Zwift tech support. In the end Tacx sent out a n new ANT+ dongle to see if that was it however sadly no better. In the end I just gave up however now its winter again i quite fancy the workout module. Normal resistance is fine on ‘normal’ cycling around watopia for example. Glad its not only me