Zwift/Neo not connecting Bluetooth BUT Tacx Trainer Works Fine

I have a Tacx Neo 2 and have been using in conjunction with iPad with no problems for last two winters. Set up bike today and turned everything on - did Firmware update, checked Zwift update etc. Turned on Zwift and no connection to Neo (no blue light on trainer). Connected fine to Tacx app (hence firmware update). Have disconnected trainer from Tacx apps, have rebooted iPad and reloaded Zwift. Looked on forums and checked Zwift has bluetooth access, quit all Tacx apps. Zwift doesn’t see my HRM either but phone and iPad see it… I just paid my monthly subscription for nothing. Maybe I should just switch to Tacx or Rouvy!

Have you tried force-quitting all of the other apps (not just closed them)? And also checked to see that the trainer isn’t connected directly to the iPad, but only through the Zwift app? I use a Neo 2 regularly with iPad and ATV and have never had an issue when force-quitting all other apps prior to using Zwift.

Read this thread in it’s entirety:

The “dummy” being me. Don’t be like me.

Thanks for both replies but I really don’t have any device connected. Today I switched off phone, I quit every App on iPad and tried to connect on Zwift - it just kept on “searching……” with no joy. No Bluetooth light appeared. Switched on Tacx Training App - bluetooth light appeared immediately and connected to app! The Neo has no buttons to reboot/reset etc - what the hell has happened since April when I turned off the trainer and put it away until yesterday. Is there Zwift support line anywhere!

Have you also tried unplugging the Neo for a bit to see if that helps it? I’m not having any issues with my Neo 2 connecting, and not seeing other posts on this, so I’m reasonably sure it’s not a Zwift issue.

Yep tried that too - I’m flummoxed!

I have no idea why but just loaded App on iPhone… clicked all the boxes etc and it has found the Neo! Hoping iPad will respond now too…

1 Like