Zwift Mobile Link power-up button doesn't work

I’ve not been able to activate power-ups using the mobile app (and my PC is too far away to hit the space bar!). My phone appears to have good connectivity (current stats displayed correctly, the power-up button appears when I receive one in-game), and other buttons (like the turns) work. When I tap the button, its animation (slight color change) acknowledges the action, but it doesn’t have any effect. Is there a technique to tapping the button the right way? I’ve tried to tap and hold, swipe, etc. Just once I’d like to ride with a van over my head!

Tapping it should work. What power-ups have you tried?

draft boost and featherweight

You should have seen a symbol of a truck on the screen for the draft boost and a feather symbol for the featherweight.

Take a look at this for more info:


Yes, there were those symbols on the screen - and the corresponding buttons on the mobile app. But tapping the button hasn’t worked ever. I’ve tried quite a few times now.

Rob, I’m creating an email ticket for you, so keep an eye on your inbox for more information on the next troubleshooting steps.


Confirmed today that tapping the space bar on my laptop works as expected. I think I got the mobile button to work ONCE today. Maybe the button is unfortunately placed relative to the sensitivity of my touchscreen? It’s a common Samsung Core Prime phone, I don’t have problems with any other apps.

Hi, I am using an iPhone and am having this problem, it only started about a week ago. My laptop is too far away to hit the spacebar everytime I get a powerup.

Zwift is there a fix for this?