Zwift Losing Connection when using AirPlay

During TdF and TdFFAS I would use my iphone to stream the race (Peacock app) and AirPlay to AppleTV 4k. Then I would start Zwift and little PIP was the race. No issues and would not use phone for any other activity. This morning tried the same set up exactly and while trying to do both a Zwift workout and just ride, all trainer connections to Zwift dropped. Tried many different approaches but all seemed to drop. I have my trainer (Neo 2T) using Bluetooth with AppleTV, not paired through my phone. Any thoughts? Is this a new bug with the IOS 16.6 like I have seen on the iPads? Thanks as Vuelta is starting soon!

Still no solution. I start something from my device (tried on both iPhone and iPad), shrink the window. Then I go and open Zwift. Get riding on Zwift and everything is brilliant. Now, the instant I switch back to what I was streaming on the PiP to get the audio, Zwift stops. When I open menu it says “PAUSED’ across the top and I can not start it again. I have tried multiple devices and combinations but all have failed me. If anyone has an idea please let me know as would be terrible if this cool feature is not longer available.

Same for me. I often used this feature to view programs while training. But since the last update it doesn’t work. :frowning:

Hopefully they can fix it

I have been sending Zwift info and they have been asking questions about using other apps. Here is what I sent in case anyone else might have some insights.

I was able to do some testing on a variety of options as requested. Please also note I have ensured I had the most recent version of all the apps, including the just release IOS update.

It was asked for me to try other apps. Using Zwift on the AppleTV, I tested using my traditional cycling event watch apps: Peacock, GCN+, YouTube, FloSports, RedBull.
Streaming from both an iPhone (includes cellular) and iPad Pro (only Wi-Fi) I was able to verify the same issues. When I move back from Zwift to the PIP window for audio, Zwift pauses. And not only does it pause, there seems to be no way to get it started again other than closing and restarting.

In addition, I started a movie on the AppleTV, used PiP, then opened Zwift. So everything was on the same device with no AirPlay. The exact same thing happened, where Zwift would pause the minute I moved back to listen to the other window.

I also just went into all the settings to allow cross app tracking in case that was it, but still did not work. Maybe something we just can’t do anymore which would be a bummer as something I use all the time.

For me zwift pauses when pip. Then i have to close the pip window and since it loses all connection i need to reconnect sensors in pause menu.

Will try more next time i am zwiftning

Yes. I had to exit all the way out of Zwift to get it to restart as well.

Worked for me today. Started zwift, started pip from iphone to ATV then the connection to sensors and started the event. Worked just fine :slight_smile:

Excellent! Thanks for letting me know. I saw where there was a new update so was hoping it was fixed. Thrilled to hear it worked for you!

Tried this morning. No joy. Seems like system says - you are not on Zwift so we are pausing everything. Frustrating for me.

Sorry to hear. Tried the other way around. Starting and event and after that airplay to ATV so i could get pip (as ive done before) but that is still not working. It dropped the connection to sensors and i had stop the airplay, go to the menu and press the pair button and everything pop up/started to work.

That connection loss didnt happen before. The connection was still running in the background whilst starting airplay.

Now it only work with airplay/pip for me when i start zwift, wait at the title screen, starts airplay and set pip, the proceed to log on to zwift and pair sensors and then start whatever event or training i want to do.