Zwift keeps pushing me to walk / run faster

Hi,

I am new to Zwift and I have just started using the Run Pod and started using the Zwift app.

I am a 74 year old male diabetic and I have been advised to walk for 30 minutes per day, at a brisk walk. Zwift lets me do that but I have two problems:

  1. The app keeps telling me I am running when I am walking (at 5Kph).
  2. It keeps telling me to speed up.

Is there any way I can use Zwift to make my 30-minute walks pleasant but without pushing me so much?

Thanks,
Andrew

It sounds like you are selecting a workout.

If you just want to walk then you need to do a free run by selecting a course from a world.

Do you mean your avatar on screen is running when you are walking on your treadmill?

2 Likes

Hi Stuart,

Thanks for your advice. I selected a world route - Duchy Estate in Harrogate - and that worked very well. I had a very pleasant 30-minute walk.

This is an excellent way of getting the exercise I need.

Best wishes,
Andrew

3 Likes

Great news. Enjoy racking up the miles and earning rewards.

Stuart, I’m going to suggest that someone at Zwift also have a very, very long hard think about the canned blurbs from the Pace Riders that suggest people ignore pain.

My partner works in orthopedics. When they saw that the first time, they said “I can only imagine how many eager lawyers are reading that.”

Zwift should not be telling users to ignore pain.

1 Like

Wow, is that the world we live in where somebody could take a lawsuit out based on that?

If so that’s really sad.

It’s supposed to be a motivational point to try and focus away from fatigue and concentrate on form.

Nobody has told Jens Voigt that “shut up legs” could land him in a courtroom.

If the text came up and said ‘go run in front of a bus’ i wouldn’t.

For me pain isn’t necessarily a sign that if i continue I’m going to cause an injury. If so I’d never run or ride again.

3 Likes

Couldn’t agree more with you, Stuart. But yes, some people really would. I’d hope the suits would be thrown out for being frivolous, but still.

It seems that modern English – and other languages that I’ve had contact with – lack a proper distinction between ‘pain’ as in ‘a serious risk to my health that my body is signalling to me to stop causing/allowing ASAP’ and ‘pain’ as in ‘a very uncomfortable experience, when compared to sitting on my backside and just breathing easily’.

1 Like

I also just ride right into others when out on the roads IRL now because in Zwift my avatar just goes right through them, so if I get injured I can sue Zwift right?

:man_facepalming:

3 Likes

Hi again Stuart,

I am enjoying using the world routes on my Mac but I can’t see how to get to them on my iPad. I would rather use my iPad because it’s hard to reach the mouse on my Mac while I am on the treadmill.

Is there a way of getting to real world routes on the iPad Zwift App? Or on the Zwift companion app? (I am finding it hard to work out which app to use in different scenarios.)

Thanks,
Andrew

Hi Andrew.

To the best of my knowledge both your iMac and Ipad will both now have the new home screen so provided you have installed the Zwift app on the iPad it should look identical to the iMac.

It sounds like you’ve installed the companion app on the iPad?
The companion app (ZCA) compliments the game app but you cannot use the companion app alone. The idea is the ZCA runs on a tablet or phone and eliminates the need for you to need a mouse.
Once you are in game and moving you can do everything you would need a mouse for using the ZCA.

I have an old phone velcro attached to my treadmill so i can change direction, gives ride ons etc…

This may explain it better.

Ignore the stuff about using it as a bridge as you’re not needing that.

Hi Stuart,

Thanks for your reply.

I still can’t find a way of getting to world routes on my iPad. But now on your advice I am running the main Zwift app on my Mac with the Zwift companion on my iPhone. That removes the need to use the mouse on my Mac, as long as I get to the selected world route on my Mac and start it up before I start walking.

I now find that quite often my avatar stops walking and its speed drops to zero for a few seconds. Is this normal? Or is there something wrong with my Zwift runpod?

Sorry for so many questions but your answers are helping me a lot.

Regards,
Andrew

It sounds like your Zwift run pod is suffering temporary drop outs causing your avatar to stop.

I’m afraid this isn’t uncommon with the Zwift pod, it’s not got the best of reputations.

You may want to consider alternate ways or recording your speed. There are other manufacturers of pods out there but by far and away the market leader is the Stryd. Expensive yes but accurate.

You could also consider using an app on your iphone to record the speed. If you are walking at a consistent pace you could use and app to tell Zwift how fast you are walking. If you increase or decrease the treadmill pace then you do the same on the app to match the treadmill. It’s great if you rarely change pace.

Also the NPE Runn is a nice little device you attach to your treadmill. This will then record your speed based on the treadmill belt. It can be calibrated to match.

Finally if your treadmill is BT enabled there may be a way of interacting with it to get the speed. There is an app that can interpret this and tell Zwift. I’ve written much about this in other posts.

Without being insulting you are at early stages in your Zwift journey and you probably need something very simple and straightforward.

Hi Stuart,

Thanks for your reply. It’s disappointing to discover I wasted my money with Zwift Runpod and now I have to buy something more expensive.

The drop-out problem has got a lot worse since I started using Zwift Companion on my iPhone. Could that be interfering with my runpod pairing, do you think?

I’ll try again today with no Zwift companion running.

Thanks again,
Andrew

I’d maybe experiment. It could be interference.

Try using the companion app as a bridge to see if that helps.

Also try and get your iPad working to see if it drops out using a totally different device.

The easiest solution is to purchase an ant+ dongle and connect via that than Bluetooth.

Ant+ is more stable and less prone to interference.

Thanks Stuart, I’ll do some experiments.

Regards,
Andrew