Zwift hangs up on my iPhone X

Brand new Zwift user as of last night.  I’m trying to use Zwift on my iPhone X.  It has paired easily and quickly with my new CycleOps Hammer trainer.  Next steps include setting my gender, height, and weight.  I’ve tried a dozen times, but cannot get past setting my gender.  Zwift becomes unresponsive when the Height and Weight screen comes up.  Can go no further.  Have tried a dozen times this morning with no luck.  I’ve searched the knowledge base and user forum with no luck yet. 

Not sure why the issue but there are two alternative ways to update your profile either on the web or the Zwift Companion app.

Works fine using the PC; but I don’t have Bluetooth or Ant on the PC.  

Now updating my iPHone X and will restart everything to see if I can get it to work.  Anxious to ride.  It’s 40f and raining outside.  Perfect Zwift weather. 

No joy.  I’ve been working with this for 3-1/2 hours now.  I was able to update my profile on the PC.  But still, the Zwift iPhone app simply hangs up and becomes unresponsive after about 3 second upon pressing “Ride” or “Watch”.  I see people riding for about 3 seconds, then it freezes.  I even tried spinning up my CycleOps Hammer before pressing “Ride” on the app.  The app worked long enough to see my image pull out into the road with the other cyclists . . . . and then froze.  

This is an iPhone X and it’s supposed to be compatible.  

I’ve even rebooted my iPhone and deleted the Zwift app and re-installed it.  My iPhone doesn’t exhibit any other issues at all.  But  for some reason, it doesn’t like Zwift. 

Tech Support responded to my request for help very, very quickly.  Kudos to them for that.  But their reply was, “We don’t know why that’s happening.”   They have not responded to my subsequent emails in a couple of hours.  Are they ignoring me?  My emails were all very cordial and nice.  

I want to ride!

 

Sorry to hear that. Can your PC tether to your phone so you can ride? I am on an iPhone X and it’s working without an issue so the support team will probably need more info and time to diagnose the issue.

Thank you, Eric.  I wonder if you’re using the Zwift app revision that is dated 12/15/2017.  Since I just installed the app this morning, that’s the revision I got.  

For a work-around, I’m going to install a USB to Bluetooth dongle on my PC.  But this means that I can only ride in the office watching the smallish monitor.  Hopefully eventually I’ll be able to watch the big screen while training. 

 

@Ken - I responded to your ticket with some further troubleshooting suggestions. Let’s move the conversation over there, and we’ll work with you further to figure out what’s going on. Thanks for your patience and understanding!

Thank you, Jason.  Going to email.