Issue with latest update December 18th

No longer able to log in using my app on I phone. Hangs on log in
Everything is up to date it just won’t load

After deleting and reinstalling it I managed to lose once and then the next time I tried to use it it failed

Was all good before the update

Same. Of course, zero support on this website.

Zwift, the newest version of your IOS app was not ready for release. Please revert to previous version, or at least make previous version available as an optional download (standard App Store feature) for those having the issue. I’m posting this in several threads hoping to get attention: No issues with Zwift until loaded newest app update yesterday (version 1.0.60239). Now launch Zwift, select profile, expect to see pairing screen. Instead the spinner (the one to the right of my User Name) runs for a moment and then stops. The app has crashed / hung with the UI completely frozen. Sometimes app closes after a moment, others it simply remains froze until I kill the app. Device: iPhone 12 Pro Max, IOS 14.3. Help! Major bummer!

1 Like

Posting it in multiple threads just comes over as spammy, and is annoying to read the same thing several times. I can appreciate you’re frustrated, but it’s going to make zero difference to Zwift’s response to do this.


Thanks for the advice Steve. I totally get that. I’m very new to Zwift and I’m really just looking to understand how much they pay attention to this forum. Hoping for some form of resolution in short order as for me for now Zwift just became unusable.


The don’t pay attention to this forum. That said they invited a bunch of users to become “Ambassadors” to create the perception of support.

That said, it seems that in this void, users step up to help which is good. I got my iPhone to work. Here’s how:

I started Zwift and clicked on change user. I entered my email/password and it froze as usual. I quit the app, uninstalled, rebooted, and installed the app. It started fresh (asking for health permissions, etc, and I was able to login. Give it a shot. Hopefully that works for you.


Yeah it doesn’t stay working for for long I have managed to log in a couple of times like that but it after a couple of times it then goes back to being stock

The one thing I noted is thebackground image seems to change.and it always locks on the same back ground image

A windy road it may be coincidence

Also if you look at the log file you can see it failing to load tonnes of stuff

That method worked for one go for me, but next time i logged in, it hung again. But if you are desperate it might get you riding.

And not one comment from Zwift staff even acknowledging this? Might as well rename this sub-forum to “Bugs”.


Same issue for me… haven’t found any workarounds…

The work around method they say is use another device for the moment there is another string about this now

Same issue here. iPhone 11 iOS 14.3. I have re-installed app 3 times. App will run ok once or twice then hangs on launch. This time when I re-installed, I chose not to connect to Apple Health to see if that helps.

Hey guys!

Thanks for letting us know about this, please email us at with your device logs so we can take a look into this for you! how to find you logs is detailed in this article, and isn’t possible on Apple TV.

We look forward to working with you to find the resolution to this issue!

I just wanted to get back to you guys that thanks to Members letting us know about the issue we found the root cause of the issue and are working to get a fix in a future game update

In the meantime, you can work around the issue using the following methods:

  1. Use an alternate platform for the game if possible- issue is only occurring on iOS
  2. Uninstall/reinstall the game on iOS and DO NOT pair Apple Watch for heart rate - the Apple Watch pairing on subsequent sessions is causing the issue

Thanks for letting us know about this!

Ride On!

A shoutout for getting on top of the issue quickly. Yae, I’m up and Zwifting again with the workaround of not pairing Apple Watch for HR.

Happy holiday, happy Zwifting!

Tried the work around and still no go - very frustrating. Quiting on both iPhone 12 Pro and IPad Air 4th gen.

Sorry Seth, your workaround isn’t working for me.

  • I switched my Apple Watch off
  • Deinstalled Zwift from my iPad Pro (2019)
  • Restart my iPad
  • Reinstalled Zwift

It crash after the user-selection.

I appreciate it, that the Zwift-Team is working on this Issue during the holidays.
I wish you all the best.

I’m having this issue as well.

Same issue. I’ve turned off my Apple Watch, and re-installed the Zwift app. I’ve also uninstalled the Wahoo app to make sure it doesn’t grab the Bluetooth connection. I’ve found another ride app (Sufferfest) which has some nice features, so when the Zwift team fixes this issue I’ll have to decide which app to stick with.

Thank you for suggesting the other app! I had to uninstall Zwift due to this problem and unsubscribe. I hope to find some better support/stability experience somewhere else.