Zwift Freeze of Death, then crashes. v1.29.0 (Memory leak in Makuri)

I was just doing a solo ride on Sleepless City and upon entering Castle Park Sprint Section, the game instantly dropped fps, stuttered like crazy and also frooze a few times. However, it recovered after a few secs and I was able to continue my ride and I didn’t encounter any fps drops or freezes in other parts of Neokyo. As soon as I was entering Castle Park Sprint area for the second time, the game frooze to a standstill.

My Laptop didn’t accept any inputs either, so i just let it stay in this froozen state as I wanted to finish my training ride. About 10mins later, I got a Blue Screen of Windows and my Laptop restarted. I collected the logs and could see in the event viewer that zwiftapp.exe had an out of memory error.

Screenshot 2022-09-21 082824

Here is the log from Zwiftalyzer:

You can clearly see where the game frooze to a standstill. The fps shown afterwards aren’t true, it was a complete still picture, like this.

My avatar lost his torso, arms and legs and was riding only with empty shoes and a head. I can provide additional logs as needed

Are you still not running OBS?

1 Like

That aside, it looks like you lost internet connection just before it all went wrong. Check in the log file and see what it shows at the end, before the crash.

If so, it probably won’t surprise you to learn that I’ve raised this [game-breaking] issue before with zero acknowledgement from ZHQ. :+1: Game Update 1.26 [June 2022] - #102 by Dave_ZPCMR

You definitely shouldn’t have a BSOD though, that’s much more concerning.

@Dave_ZPCMR I didn’t install it so far. I’ll give it a try.

Logs show this:

[8:04:36] NETCLIENT:[INFO] Failed one leg latency threshold test.  [min: 662, avg: 1211, max: 2052, n: 6]

[8:04:36] ANT  : Rx Fail on channel 1

[8:04:36] NETCLIENT:[INFO] UDP metrics {StC Rx: 450, Rx error: 0, CtS Tx: 233, Tx error: 0}

[8:04:39] ANT  : Rx Fail on channel 1

[8:04:44] ANT  : Rx Fail on channel 1

[8:04:46] FPS 58.82, -593018, 21837, 57166

[8:04:53] Giant dt in app. dt = 33.23

[8:04:54] Received player packet older than 10 seconds -- ignored (616111459 vs 616077890)

[8:04:54] ANT  : Rx Fail on channel 1

[8:04:54] Received player packet older than 10 seconds -- ignored (616111459 vs 616077803)

[8:04:54] Received player packet older than 10 seconds -- ignored (616111459 vs 616077777)

[8:04:54] Received player packet older than 10 seconds -- ignored (616111459 vs 616077851)

[8:04:54] Received player packet older than 10 seconds -- ignored (616111459 vs 616077855)

[8:04:54] Received player packet older than 10 seconds -- ignored (616111459 vs 616077759)

[8:04:54] Received player packet older than 10 seconds -- ignored (616111459 vs 616077798)

This continues a lot, like 4000 rows.

Then, after this I got:

[8:05:36] NETCLIENT:[INFO] Failed one leg latency threshold test.  [min: 501, avg: 825, max: 1693, n: 67]

[8:05:36] NETCLIENT:[INFO] UDP metrics {StC Rx: 476, Rx error: 0, CtS Tx: 20, Tx error: 0}

[8:05:41] NETCLIENT:[INFO] Sending telemetry...

[8:05:41] ANT  : Rx Fail on channel 1

[8:05:43] NETCLIENT:[WARN] UDP connection timeout (1 so far), reconnection attempt 1

[8:05:43] NETCLIENT:[INFO] Connecting to UDP server...

[8:05:55] NETCLIENT:[WARN] UDP connection timeout (2 so far), reconnection attempt 2

[8:06:07] NETCLIENT:[WARN] UDP connection timeout (3 so far), reconnection attempt 3

[8:06:07] NETCLIENT:[INFO] Connecting to UDP server...

[8:06:18] NETCLIENT:[INFO] UDP host 52.12.227.3:3024 (secure)

[8:06:18] NETCLIENT:[INFO] Connecting to UDP server...

[8:06:28] NETCLIENT:[WARN] UDP connection timeout (4 so far), reconnection attempt 4

[8:06:28] NETCLIENT:[INFO] Connecting to UDP server...

[8:06:37] NETCLIENT:[INFO] UDP metrics {StC Rx: 0, Rx error: 0, CtS Tx: 0, Tx error: 0}

[8:06:38] ANT  : Rx Fail on channel 1

[8:06:39] NETCLIENT:[INFO] UDP host 35.91.167.46:3024 (secure)

[8:06:39] NETCLIENT:[INFO] Connecting to UDP server...

[8:06:41] NETCLIENT:[INFO] UDP host 52.12.227.3:3024 (secure)

[8:06:41] NETCLIENT:[INFO] Connecting to UDP server...

[8:06:45] NETCLIENT:[INFO] UDP host 35.91.167.46:3024 (secure)

[8:09:39] NETCLIENT:[WARN] UDP connection timeout (10 so far), reconnection attempt 10

[8:09:40] NETCLIENT:[INFO] Connecting to UDP server...

[8:09:42] NETCLIENT:[INFO] UDP metrics {StC Rx: 0, Rx error: 0, CtS Tx: 0, Tx error: 0}

[8:09:42] ANT  : Rx Fail on channel 1

[8:09:45] ANT  : Rx Fail on channel 1

[8:09:49] NETCLIENT:[WARN] Request timed out for: POST https://us-or-rly101.zwift.com/hvc-ingestion-service/batch

[8:09:49] NETCLIENT:[INFO] Sending telemetry...

last rows show this:

[8:16:39] NETCLIENT:[WARN] UDP connection timeout (22 so far), reconnection attempt 22

[8:16:41] ANT  : Rx Fail on channel 1

[8:16:41] ANT  : Rx Fail on channel 1

[8:16:41] ANT  : Rx Fail on channel 1

[8:16:41] ANT  : Rx Fail on channel 1

[8:16:41] ANT  : Rx Fail on channel 1

[8:16:41] ANT  : Rx Fail on channel 1

[8:16:41] ANT  : Rx Fail on channel 1

[8:16:41] ANT  : Rx Fail on channel 1

[8:16:41] ANT  : Rx Fail on channel 1

[8:16:42] NETCLIENT:[INFO] Connecting to UDP server..

Seems like there was an issue with connectivity.

Yeah what happened with mine is the internet dropped during the game loading so when it got there it was already shagged. It sounds like yours dropped off and instead of everyone else just disappearing but everything carrying on as normal (as has historically been used for solo riding and testing etc) it knackers the whole game. I’ve also noticed in recent months that with the internet disconnected it stutters like mad for some reason - probably the same thing.

Anyway you should definitely run OBS, but that’s a separate thing to this.

What bothers me is that this behavior occured in the very same world spot in Makuri. If it’s a connection issue, then it would have been everywhere in the game.

But it happened twice in the same location in Makuri. First time fps went down and stuttered like crazy, even frooze for a few seconds, then the game recovered from it. Second time visiting the same location it started to stutter as well and then just frooze to death and crashed with BSOD after a few minutes. Between first and second time, I was able to ride just fine like this issue never happened.

Whats interesting is that the first time it happened seems to not appear in the logs at all and even not in Zwiftalizer output.

There are definitely some spots in Neokyo where there’s a massive dip in performance for no apparent reason, so maybe it’s one of those.

I know I keep banging on about it but you should run OBS as soon as possible. The game on PC is utter rubbish without it (and has been for ages), with the frame pacing completely wrecked. Some people see this most clearly as avatar flickering, some see the stutter, some get crashing problems. You may have had everything. The reality is OBS running in the background (not doing anything, just loaded) fixes them all.

I’ve noticed that avatars, my own included, seem to be more ‘jerky’, almost like a Disney boat ride. Suddenly swerving to keep a corner. It’s a little distracting on tight corners. It seemed like it used to be more fluid in the past.

I already have OBS installed and setup to autostart in the background. I’ll have my next Zwift session tomorrow in the morning so I’ll keep an eye on the changes. Microstutters was also something I definitely experienced, but I never hat a freeze or crash.

1 Like

Set it to run minimised and disable automatic updates, then copy the shortcut into shell:startup. It’ll set itself going at boot and just sit in the system tray never to bother you again. Set and forget.

OBS didn’t solve the heavy flickering issue in the custom workouts screen. At least that’s what I can tell so far. But this is a separate issue.

I owe you a fiver then. :frowning:

Assume you have vsync enabled? It should be. Leave it on ‘use the 3D application setting’, as default. And are you using windowed mode or full screen, out of interest?

V-Sync isn’t enabled. Just set the Triple Buffering to On and the NVidia Card as the graphic processor to use. Using Full Screen Mode.

‘Use the 3D application setting’ is the same as enabled, for Zwift. So unless you’ve specifically disabled it then you already have it enabled.

Okay, it’s enabled then. Microstutters are gone since OBS is running in the background, so the fiver is back to you then. :wink:

1 Like

To be honest it was the stutter that I noticed immediately. The avatar flickering at high frame rates (they both happen) is just easier to demonstrate. I even sold a graphics card for parts believing it to be faulty before making the link.